Simulator doesn't start anymore at all

tried to repair, 3 times reboot… then tried from xbox applciation to launch the game…all games from xbox like Forza Horizon 4 are launched well…
For now, i just removed the game and it downloads again… Will see later after downloading if it goes.
Thanks man for trying to help…

okay… but if this not helps, don’t re-install again, it is just not helpfully if its former worked fine :wink:

Sometime there are network issues which prevent that the app starts. Then connections should be checked within these xbox app ( but should normaly no longer necessary )… the ms-store should be checked… possible simple restart your router…

But let us know what happens :slight_smile:

It’s very strange what you say, if all games are launched well from xbox and all syncronized well then i don’t believe something is related to network issues. Anyway, it download again whole 100 and somethign GB. Let’s see if starts. I will update later.
Thanks for advise.

a note about: there is not one single server in the world for all the existing games :wink:

1 Like

Hi buddy, same issue. I literally have to restart my computer 2-3 times and try to launch it through the Xbox app to get it running. Any fix you know of? It used to work, but after all the updates and me not playing for a little more than a month, it no longer works & I can’t refund either since it’s through the Microsoft store and it’s been longer than 14 days.

Currently we wait for the result of re-installtion from @SpinalVoice2012.

You write about your issue reported a months ago ?

“aphostservice.dll” seems strange…

Please try:
1 dism /Online /Cleanup-Image /ScanHealth
2 dism /Online /Cleanup-Image /CheckHealth
3 Incase of error reporting: dism /Online /Cleanup-Image /RestoreHealth
4 sfc /scannow
5 restart

Hi, thank you for your suggestions.

In event viewer, aphostservice.dll no longer appears, & the only errors that appear are;

Session “OWEtKernelLogger” failed to start with the following error: 0xC0000022

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WSearch service.

These are the two errors I recieve. I also did the scan & health check as you suggested, but it came up with no errors, as did sfc scan.

I have the same problem with the program locking up. It appears to load everything, but it never opens the menus.

I tried everything , to repair, to reinstall and scan files but nothing helped me so far.
So for now i completely uninstalled msfs from all possible locations and now download again.
Also, i do it with no pauses . My PC will work untill it downloads full.
Will see later.

After 6 hours of download and install process , yes it’s worked FINALLY!!! :sunglasses:

you have definitiy windows issues…

WSearch is windows search service.

And this 0…22 at “OWEtKernelLogger,… was this a Blue Screen ?

The only idea I have in mind is/was to repair windows with former mentioned commands :-/

Hi Micha,
I have found a long-term, working, solution.

You were right, the aphostservice.dll & Kernell Logger continued to appear in my event log, even though I thought they had resolved themselves. I decided to do the last thing viable; a windows reset. I watched this tutorial video -
https://www.microsoft.com/en-us/videoplayer/embed/RE201WL
& it kept all of my personal files & apps, while just reinstalling windows. This worked perfectly, and I can now start MFS2020 without any issues. For anyone else having this issue, I would suggest this. Do not reinstall MFS2020 unless you think it’s necessary, I’ve reinstalled 3 times & none worked. If you’re like me, the sim would open sometimes as a hit-or-miss, and I contacted zendesk. I’ve already cancelled my zendesk ticket to the support team, and I wouldn’t suggest reaching out to them unless you’re comfortable waiting 4-5 weeks for a reply for a list of solutions already available on their FAQ.

Thanks,
Tate

1 Like

good to hear… or read :slight_smile:

and yes… it is this the so called " in-place repair / upgrade " :slight_smile:

the MS page about is:
https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/how-to-perform-an-in-place-upgrade-with-windows-10/7f0b236e-3c6c-4913-9691-c4baa2a6190a

Hi guys, I think I should add here that I reached out to my anti-virus and they helped me through adding the microsoft communication programs as exclusions, and I can now launch the sim with my anti-virus turned on. Previously, the sim only launched after I completed the in-place repair / upgrade with my AV turned off, and once I turned it back on, the same problem continued.
Hope this helps, save some time from talking to zendesk.

Thanks - I tried this today and was very hopeful but it didn’t work for me. Does the game then need to be reinstalled once the Win “in-place repair/upgrade” is done? I am trying this now and have tried all other fixes in this forum with still no luck.

Once I re-install I get a few days of normal launching and then it reverts to the stuck blue bar with only ctrl,alt, del working to exit the app.

I am now on install 7…

1 Like

Hi,

you have then other kind of issue.

Please check the windows event log ( viewer ) about ERROR entries related to Flightsimulator so we have a better starting point for searching the issue.

don’t do that :slight_smile: … we have to find the reason… these re-installing doesnt fix your issue.

ah… and I assume this kind of installation should safe your installed apps… but it is Windows, don’t expect to much :wink:


thanks for the info… thus MS Defender seems to have still an issue with MSFS… unbelievable.
In generaly I recommend to add all such big-game-folder to these exclusion lists for runtime checks and let run from time-to-time a manual check.

which AV application you had former ? It is important to know.
Now that you mentioned that, I might be that this was the root-cause.

Hi, thanks for your response. You are right : - ( despite updating windows yesterday and reinstalling FS today I can’t launch it. It gets stuck on blue bar.

Can you tell me where in event viewer I can find the information that will help?
+

The only “error” I can see at the time of launching the game is as follows:

Failed with 0x57 retrieving AppModel Runtime status for package Windows.

what exactly you have done with your windows ? Completly new installed or only installed updates ?
Which version of Windows you have ?

This error can come amongst other things from windows updates (older issue)…

here is a short howto for the windows event viewer:

just search such ERROR entries where the Flight…exe is mentioned… You should normaly not have sooo many entries of kind ERROR :slight_smile:

I did the in-place repair / upgrade as suggested in the posts above. I am using Win 10.

I can’t see any error entries with the word Flight mentioned. I have even searched within the event viewer for Flight and I can’t see anything. Is there anything obvious I should be seeing?

hmmm… okay…

It might be that you have to re-install the nvidia drivers. Download it from the nvidia homepage and install it. ( assume you have nvidia :slight_smile: )

Also… can you open “winver” or “system info” to show which version you have ?
( just click on the windows symbol and enter winver :slight_smile:

and Windows-Event-Logs…
you should easy see the Red ERRORS. You have many others of it ?
example:

And, can you also recheck, whether windows-update-page show you open updates ?