Singapore City Downtown addon ( FS 1.12.13)

After a complete sim re-installation, I am trying to install that pack that I bought from the Marketplace. Every time I try to download, after the whole 1,32GB, it failed with the last 22 bytes. Multiple attempts produce the same results. I download all the others add-ons without issues Any ideas ?

I have the same issue with Aerosoft Cologne Bonn. I am done purchasing from the Marketplace for that reason.

I can’t say that it is all that bad but it is very flaky. Download sometime don’t start or abort abruptly and they don’t remember all the megabytes downloaded. They restart again from scratch. Eventually, after few retries, you get it.

Still this one doesn’t work. I am not sure from where I am downloading that stuff since it is a third party, Microsoft or CloudSurf. Any way I sent them an email (cloudsurf) to see what they say.

Well I finally got it. I tried in the evening and it went through. I don’t know if Microsoft is looking at this but according to CloudSurf, this is coming from MS servers. So we’ll see next time. Cloudsurf suggest a VPN but I am not sure why.

I am trying to download that pack that I bought a while ago. The download just stop at about 1GB out of 1.32GB and never terminate. It says Please wait. I contact Cloudsurf but they say that MS is supplying the download. Anyone tried it ?

I had the same problem. I had to repeatedly quit and restart. Every time it would progress further.