Skynet still in the autopilot, only more embedded now

Seems the AP is now not working on most of the planes I’ve tried. It literally tried to kill me instantly. It will hold NAV / HDG as long as I control altitude. If I enable ALT, FLC or VS, the plane immediately either goes into a full 90º climb, or 90º dive. So far, I’ve tried the C172, DA62, DA40 and TBM. All have exhibited this behaviour. The second one of the altitude control modes are selected, it goes bonkers.

Anyone else seeing this?

It’s something to do with your controller sensitivity ( set it above 5 % ) .

Regards , John ( Connor ) .

Thanks for the reply, but not sure what you mean there. It’s the same it’s always been. I would occasionally have this issue once in a while, but since the patch, it’s been present in all planes, all the time. I haven’t changed anything in my controls since I got this controller a month ago.

I have performed a single flight with the TBM since the patch
I did not encounter a suicidal Autopilot. But it wasn’t clean flying either.

VS altitude change was smooth for me, both in climbs and descent
FLC was hit and miss (a little bit of Dolphin dancing)

A very obvious defect was altitude intercepts which was clearly working with a series of preset preprogrammed VS steps and was very slow to reach the desired altitude.
When using FLC, the first steps of the altitude intercept were very rocky, with the AP targeting the successive VS speeds, then returning to FLC logic, only to do it again a few hundred feet later.

I also noticed the heading changes were non standard 30° of bank regardless of speed.
Pressing the BANK button reduced it to a non standard 15° of bank regardless of speed as well.
When reaching the desired heading, the intercept also worked in steps, they were less obvious than the altitude intercepts but there were just also very slow to actually reach the target heading

Tried an ILS approach : the autopilot was rocky on the glide intercept, and then had a very stable and smooth descent but slightly below the slope (similar to previous version).

I do not know what happens with controller sensitivity, but my sensitivity settings for both pitch and roll are linear (0%)

1 Like

It seems that the patch reset my controller sensitivity. I used to have my axes at -50% with a 5% dead zone. They were all reset to default after the patch. I reset them and my autopilot seems to be behaving a little better than it was previously. Far less erratic and suicidal like it was.

Still though, I’m not sure why my controller input calibration settings should be linked to my AP. That just seems wrong to me.