Slow Download Speed Megathread

Multiple users around the world in different countries have incredible low download speeds, f.e. ISP Connection 120mbit, but MSFS2020 is downloading only with 1 to 20 mbit/s. The problem is there since release and is touching not only the download for the whole game or major updates, but also the ingame download through the marketplace.

Multiple users are reporting that at the same time, online speedtest and f.e Steam downloads have no problem and are giving the full download speed bandwith, so that it appears that it´s not a individual connection problem. Often the only thing which helps them is using a VPN and trying out different servers, sometimes even in the same country as they are located.

Can we please get any official feedback, at least that the problem is aknowledged ?


I have a few suggestions for people to try that will hopefully at least help some people to get download speeds improved.
I’ve posted some of this this in a few threads since the SU5 update. But here’s the full story.

I live in the UK and am lucky enough to have a Virgin Media cable connection of 300MBps Down/ 30Mbps Up. I originally downloaded the game on the first day of it’s release in August 2020.

I managed to download the whole installation in about 2 hours with the max speed shown on some of the larger files at over 250MBps.
Subsequent updates all downloaded very quickly and in line with my expectations of a 300MBps connection.

However sometime around SU3 I was suddenly getting around 10-30 MBps even though my speed was testing out ok on several different test sites.
It’s been like that on all the updates (world and sim) since then.

I just assumed it was either the servers being overloaded or maybe my ISP was throttling certain types of traffic, I did contact them and they denied any throttling.

For SU5 I decided to see what I was getting and if it was still slow see if I could do anything about it.

I started the download and it was pretty slow at between 5 and 30Mbps, left it running while I cooked my dinner and checked again about an hour later to find it had only managed about 4%.

I googled some previous suggestions on slow speeds and with a bit of tweaking I got my connection back up to full speed.

Since MSFS is a Windows app it seems to benefit from the Windows delivery optimisation settings being enabled.
I’m assuming this works a bit like torrents with portions of the files being downloaded from a multitude of PC’s on the net.

Also in one of the official MS posts on download problems it mentions a command prompt command that might help.
In this suggestion it mentions disabling a certain parameter.
I don’t recall changing mine from default but it appears I had got this set to disabled. I found that setting it back to normal again along with the Windows delivery optimisations jumped my speed up from 30 to 300 MBps again.

Obviously I can’t say it will fix anyone elses problems as there are so many variables, but here’s what I did to get mine back to normal.
First off from Windows settings go to update & security

Then select delivery optimisation

Then set allow downloads from other PC’s and also PC’s on my local network and on the internet.

Then go to advanced options and set as per picture.

Next open up a command prompt as administrator (google this if you aren’t sure how.

And type this command

Now this is where it gets a bit uncertain in that the autotuning level=normal part is usually the default setting so you may already be set with that but I had it set to disabled.
So if you don’t see any change try setting it to disabled first then back to normal again.

After I’d done that (whilst the download was still running by the way) is suddenly started increasing in speed up to about 70 at first then after 10 minutes I was getting the full 300MBps.

I hope this helps some of you, good luck :crossed_fingers:


I just tried every step exactly like its shown on your screenshots, but unfortunately it doesnt change anything for me.

The only thing which helps me is using a free VPN.
So for anyone who tried every step and is still suffering from download speeds like it is 2001 and doesnt want to pay for a VPN or give credit card informations:

1.) Google for ProtonVPN, register, download and install (absolutely no payment or credit card information is needed for the free servers from the USA, Nethlerlands and Japan
2.) Try every server from the USA, on Server 3, 4 and 8 I get at least 40 mbit, sometimes 70mbit (with a 120mbit connection), still not what I should get with my connection, but better than the 10mbit I get without VPN


Turn off IPv6 if it is on. Like magic for me, hopefully for you.


I have a VPN and have tried that in the past selecting various locations around the globe but it made no difference.

Did you try the netsh command with disable in place of the normal first, and then switch it back to normal?

1 Like

Yes I tried the netsh command multiple times.
Its unbelievable that we have to guess and try so many things. That´s not an Indie Studio, Its good old Microsoft.


I too (like so many of you) have recently started experiencing very slow download speeds. I’ve tried all of the suggestions posted online and the only thing that improves things at all for me is using a VPN which bumps me up from 5-10 mbps without to 30-70mbps with VPN. I used to install at 300mbps+ up until about 2 months ago. I’ve done a lot of testing including buying a 2nd copy of the game on another computer to see if the issue was just my PC. It isn’t. I’ve bypassed my router by plugging directly into my ISP’s router/modem and the performance is only slightly better. At this point, it doesn’t appear to be anything on my own set up. I’m getting 1.4Gbps to the house (fiber) with 800+mbps download and 900+mbps upload reported by a speed test. I should be flying on these downloads and very disappointed that I can’t get above 70mbps. Anyone else using BELL Fibe in Canada? If so, can you report your download speed?


As usual this is just normal MS behavior, all is ■■■■. In this day and age they should at least be able to deliver normal download speeds, not some back ally wannabe operation.


I use Bell Fibe in NS with 1.5 Gbps service and have always suffered with slow downloads since the Tech Alpha. Max I get is 30Mbps until I connect a VPN. With a VPN connected, I can normally get 250-300Mbps.

I’ve done a ton of troubleshooting and I believe the issue for me is an extremely slow hop between 2 Bell routers. I’ve called Bell tech support multiple times. Their answer is that the connection works and they don’t provide any troubleshooting for connections to a single endpoint. Basically saying issue is on MS’s end and they either have to fix it or they need to contact Bell engineers to fix it. Using the VPN changes the route and bypasses the slow Bell router hop.

I have all the data from my tests. I just need someone from Bell to listen. I’ve gotten as high as a level 3 manager but the result is always the same - being told to pound sand. Only hope I could see happening for us would be for something to magically change with the data centre the server is hosted in causing a change in the route my packets are taking.

I asked if all Bell customers called the service desk about the speed issue would help, they didn’t really answer. It’s really frustrating because my connection is like lightning for everything except MSFS.

The VPN connection also goes through your 2 routers, so its highly unlikely that it´s the 2 routers fault. Also basically everyone has slow download speed for msfs2020, the fault is on Asobo/Microsofts side.

There is/was/is also a known bug where: IF you have gone into DATA settings and altered your Internet Data Limit and Speed settings to lower than what your ISP delivers…the next update OR reinstall will download at a much lower speed.

There is NOTHING you can do until you get updated and reinstalled and go back into settings and fix it.

I have experienced this myself. Instead of a few hours for full reinstall it too FOUR DAYS!
I had been messing with all the DATA Settings and was trying to turn off all data streaming/cache.

Anyway. if you messed with Data settings that could be part of your problem.

That’s incorrect. When traffic traverses the internet it passes through a ridiculous amount of equipment to get from point a to point b. In my case it passes through over 10 different routers. Each of those routers use a routing table to try and figure out how to route traffic to its destination. In my case, one of those routers appears to be struggling to route the traffic which results in slow transmissions or retries on a different route.

When I use a VPN, my traffic is passing through the exact same equipment at MS but gives me significantly more speed. What I’m doing by using a VPN is not changing anything on the MS-side. I’m just changing the route the traffic is taking between the download server and my home PC.

While it may be plausible that certain configuration options on the MS servers / data Center are causing certain routers issues, just because you have a fast connection that a speed test website shows as good, doesn’t mean the speed issue we have is MS’s fault. It could be any one of the owners of the equipment that traffic is passing through.

In my case the frustrating part is slow hops I’m experiencing are equipment owned by the same National Corporation as my ISP but technically not my ISP.


Apart form the fact that I was getting good download speeds, then for a few months bad download speeds (maybe I messed up some settings) but now after making some adjustments to my network card settings and windows settings I am reliably getting close to my 300Mbps that my ISP provides.

I sent all my testing info through to Microsoft as a ticket. Most likely would only help those that are downloading from a specific server in Canada. Gave them everything I could so hopefully they use the data to trace things out.

I wish the download process allowed us to manually select a download server so that users could manually try different options if they get unusually slow connections from a particular server. From what I can tell there are a number of different distribution points and it’s selecting a server based on geographical closeness to you and not by best speed.

1 Like

@XT24, I too am a Bell Fibe subscriber and I’m in the process of submitting a ticket to Microsoft and sending them my tracert results. I am having exactly the same issue you are so I am more convinced than ever that there is a problem with Bell’s routing. I moved about 10kms and moved my Bell Fibe services with me. I have a 1.5Gbps connection and have tested that I am indeed getting this speed to the house. Even though the new house has Cat 5e throughout, I’m still getting 800+mbps down and up with an Ookla speed test and all other internet traffic flies. Flight sim updates in the old house came down at 500mbps+ but at the new house, I only get 10-30mbps without VPN and with VPN I get about 70mbps. Bell has replaced my HH3000 twice and nothing has changed. I also connected directly to the HH3000 and eliminated my own router and same result on multiple computers. I will be contacting Bell about this again but I think you’re right, there is a bad hop happening in the routing that I now go through that I didn’t go through at my old house.

I can’t tell if you’re joking or being serious with all of this? This game is hosted on one of the biggest content networks in the world. Your internet connection runs through maybe 15 to 20 hops in both directions when you connect to a server and if just one of those is overloaded then that’s it. All downloads start off slow and then hit their max speed if the connection allows it over time. Because this game downloads in small chunks of data then hitting your max speed is hard. Copy a thousand small files form one drive to another with a combined size of 100GB and it will take longer than a single file of the same size. That’s just how it is.


That’s exactly what a CDN does, Microsoft isn’t going to adjust anything on the basis of a single email from one individual concerning slow download speeds.

That’s been my suspicion too. All of the hops I go trough appear to be either Bell equipment or Microsoft equipment. I’ve tried doing the support route with Bell and gave up. The residential support just doesn’t have the ability or escalation methods to deal with something like a routing issue.

I’ve sent all my data (including tracert and pingpath) to Microsoft through Zendesk hoping that they can review and maybe deal with Bell engineers to resolve it. To tell you the truth - I expect one of these days Bell will do some upgrade or change for some unrelated reason and it’ll just fix itself magically. That hasn’t happened yet since I’ve had this issue since the Tech Alpha.

I also suggested in my ticket to allow users to swap download endpoints from a list to allow users to potentially bypass hops that may be giving them issues. Much the same way we can change game servers, why not allow us to change download servers?

Yes that would be a nice option for sure! I’ve been trying to debug this since I moved 6 weeks ago and I have hit a brick wall. I sent you a PM @XT24 with my tracert info. It would be interesting to compare mine to yours.

Im getting capped at 30mbps.
Also Im getting bandwidth warning message in-game and issues with pg and autogen not loading.

I have 100/100.

1 Like