Slow Download Speed Megathread

give proton vpn a shot and see if it works!
U.S servers recommended!
here

1 Like

VPNs do absolutely nothing with this issue.

THAT is hilarious! Great for an early Saturday morning laugh. We all share in your pain, though, if that’s any consolation…

1 Like

Not strictly true. It doesn’t fix the issue, but it can make you take a different route across the Internet, and land on a server that may not be an contended, or whatever the root cause of this is.

I have seen improvements many times, where a previous update that was coming down at ~2Mbps would jump to nearly 200Mbps. Nothing at my end changed, other than the VPN, but it would likely have connected to a different Azure CDN server.

So I would agree that a VPN won’t “fix” the issue, but it can be a workaround if you are consistently stuck at those low speeds. I only have the free Proton VPN to play with, so have the US, Japan, and Netherlands to choose from, and even then only the freely accessible ones so YMMV.

1 Like

there is no guarantee that it will be effective , but according to my exp and other folks, it’s been helpful in many cases!
anyway, the test is free and won’t harm you!

I just kicked off an install at work. This is on a Dell Optiplex 7000, Gbit connection going out through a 20GBps JANET link, so I can guarantee full 1Gbps up/down on this link.

I’ve got to the point where the sim is installed, and is downloading the various packages. Speeds a little bouncy, as you can see here.

This is just looking at incoming data. At the bottom it lists maximum, current, and average download speed. Minimum is possibly misleading as I kicked it off, then set the traffic analyser running.

Switched to Mbps view:

Looking at the current chart, running now for just under 8 minutes, it’s averaging out at 125Mbps, which is far short of the available bandwidth, and peaking at 271Mbps. The previous chart did show a large spike at 356Mbps, which is the highest I have ever seen, but given that I’ve only see it here today, and at home, that’s not a large sample size!

I can guarantee that this traffic is not managed at all. I have no QoS enabled on the firewall, and our connection to JANET similarly has no QoS or filtering, other than some sensible things like blocking unauthorised SMTP, RDP etc.

I just hit the pause button, as I’m going home soon, and you can see the traffic drop right off at the bottom right.

Just ran a quick speed test.

1 Like

Well, I just did MY first uninstall and reinstall of the complete sim since I first loaded it back in 2020! I also cleared out all of my flight hours and log records on the MSFS server(s). It’s basically a recreation of my first purchase from the MS Store.

It took my average system with a gigabit Internet connection just a little over 2 hours to complete. I didn’t sit and watch it, but when I left it it seemed to be downloading for the most part between 100 to 275 mbs. However, when I went back into the sim to download various optional content, I noticed that the speeds then dropped off dramatically - running only between 2 to 100 mbs.

However, the biggest plus from this exercise is that my MSFS boot-up to the ready to fly time has dropped dramatically from typically 2.5 to 2.75 mins to .75 to 1.0 mins ave.
Nothing in the community folder yet, though. Holding my breath!

Running another test here at work, this time graphing the IP addresses used. Here I’m not interested in what the traffic is, only the amount of data per IP. Because the system is sitting there doing pretty much nothing else, its immediately obvious which IP is sending the data.

I’ll leave this running for a bit. If the IP address changes during the install, this will show on the graph as a new IP with an increasing maximum transfer rate, while the non-MSFS related servers bubble along at tiny fractions of 1Mbps.

So far 104.212.67.92 (stor3.msedge.net) is the only IP in use.

When I see stuff like this I get suspcious. :slight_smile: It’s hit 120Mbps, and is staying at that speed.

To be fair, if I could guarantee that I would get that all the time it wouldn’t be completely terrible, but still disappointing to see that my connection isn’t being fully utilised.

Looks like I just got “throttled” further, down to 60 Mbps.

This is what MSFS is showing:

Looks like its downloading from two sources at once, the new one being 13.107.213.64. The original IP ist still bubbling along at ~50Mbps.

Third one coming online:

Two have dropped off completely, and the third one persists:

Bouncing along now on a single IP at around 120Mbps. This test started at about 15:13, when the first folder was downloaded, and the sim is just about to roll up to 24%, so if it continued at this rate it might finish in just over 2 hours total.

1 Like

The first IP you listed is located at a MS data center in São Paulo, Brazil. The second one that became active is at a MS data center in Redmond, WA. The download process is evidently dynamically shifting IP addresses as it runs, probably based on server load and other factors. Not sure where you yourself are located in the world.

1 Like

UK, Cambridge specifically. The switches seem to occur as it starts to download different files. Which would certainly explain why some users report that such, and such a file is taking ages to download, and others are faster.

2 Likes

Just purchased MU2 on Marketplace and download lingered at 2Mbps and the completion counter would frequently reset back to zero. Tried a couple of VPN locations and one magically allowed the 1.6GB download to run from start to finish at 83Mbps without any ups and downs. This clearly shows that it is a Microsoft infrastructure problem and the fact that this global Cloud provider still hasn’t addressed the issue boggles the mind.

1 Like

It doesn’t look like it’s resolved…

2 Likes

After 18 hours, there is only 52 GB left, I will inform you when it is finished.

1 Like

Day 3 of installing the sim. at this point it would be faster if i drive with my bicycle to the microsoft serverfarm, download everything on a stick and drive back. (living in germany btw).

non of the solutions in any thread are doing anything to the downloadspeed, not even using a VPN which worked a few Sim updates ago to get at least around 50Mbit/s. who am i gonna send my electricity bill?

4 Likes

Hi, I also live in germany, did you tried to donwload in the morning. I also have very bad speeds in the evening but in the mornig I get around 100 Mbits/s

I am curious if you are downloading from the MS Store or via the xBox app?

I recently reinstalled my sim from the MS Store - not xBox, and it only took about 2 hours. See my previous post. (In the U.S. on the Eastern Server.)

1 Like

I’m in the UK and tried downloading a world update at 11am this morning and got less than 3 Mbits/s. Terrible.

Cancelled the download and tried a VPN, USA (Seattle), and got about 60 Mbits/s.

2 Likes

Speeds are horrible for some packages, even through Xcloud. Peaking at 2MBs

3 Likes

Can anything be done about the very slow download speeds I’m experiencing, when i first purchased msfs2020 on the day of release i had a 150 Mbps connection i took 90 minutes to download and install. This week i had to reinstall the sim ,i now have a 550 Mbps connection and it took eight hours to dl and install also the content from the marketplace is downloading at a snails pace,sometimes as low as a 56kbps modem. Im downloading from Manchester uk and own the steam version if that helps.

3 Likes

Yeah, took forever with me. I’m using starlink, don’t live in manny but live close to it. Have been having awful bandwith while using MSFS atm too, aswell as stutters on a 2 week old PC with a Ryzen 9 7950X3D and a RTX 4080…

3 Likes