Slow updates caused by my PC, need help figuring out what is causing it


I have had issues with download speeds from the day the game launched, I have contacted the Support Desk on 4 different occasions about this issue and nothing they said had ever changed anything.

I have also tried everything in the (very short) official slow download speed articles and they have not improved the situation either. With that said, one user on the MSFS Discord was able to diagnose the issue down to the way the game tries to route my connection. They said that MSFS uses single-threaded downloads and this is directly proportional to the latency to the particular download server my PC is using.

Knowing this, they helped me change some network settings through the Command Prompt and in combination with a VPN (NordVPN), solved my issue.
Using a VPN does nothing for me anymore. The issue is back and I am stuck downloading at 4Mbit/s. It would also be worth mentioning that I have a friend who lives 10 miles away from me, uses the same ISP and has the same internet plan as I do (50Mbit/s) and has never had any issues downloading updates or streaming photogrammetry data.
I have also tried to change the DNS server and I’ve used both Cloudflare and Google, neither made any significant difference to my download speeds. For reference, my friend has always used Google DNS and once again, has never had the issues I’ve been facing.

This leads me to believe the issue is with my specific setup, either hardware or software, which makes it even worse because Support Desk has been anything but willing to look deeper into it. They have simply told me that they do not have any control over download speeds, to check their official “Slow Download Speed” guide and referring me to the Azure server status page. There, of course, are no issues with the Azure servers.

My PC specs shouldn’t matter too much but here they are:
Core i7-6700K
GTX 1070Ti
Asus Maximus VIII Hero
2x8 GB DDR4 @2133MT/s
NZXT 850 80+Gold PSU

I am stuck downloading the NZ update at 4Mbit/s and my friend has already finished it since he does not have this issue. I would greatly appreciate if anyone had the time and strength to look into this, I will provide logs, you only need to tell me which ones and how to access them.


I have downloaded Cloudflare WARP once again, I had tried it in the past but it didn’t work, it was NordVPN along with the settings the aforementioned Discord user that solved it last time.

I thought I might give it a try again and this time it did make my connection speeds much better but also made the connection itself incredibly erratic, with a lot of instances where it cuts out completely. See this screenshot of the Network tab in Task Manager.


I don’t know if this is a viable solution to use for flights, I don’t want to be bombarded by the “Lost connection” message since I use photogrammetry data streaming. I don’t want to turn this feature off because it has been branded as a core feature and is also a big reason for me using this sim.

Any ideas as to what might be causing it?