[SOLVED] Consistent stutter every second no matter my graphic settings due to Data Streaming

MSI 1080ti
32gb RAM
3440x1440 UW Monitor
CenturyLink Fiber Gigabit internet (average around 800 mbps up and down)

After a ton of digging through the settings in the game, I found what appears to be the culprit. Once I turned data streaming off, the single, consistent stutter went away completely. That is the only setting that makes any difference. My FPS are manageable, the stutter is not. Of course, the game proceeds to look terrible because of it so I don’t even want to play it unless I can stream the terrain data. I even tried data cache but the textures and mapping didn’t look anywhere near like the data stream did. This game is unplayable with this stutter. It freezes the game every second for a quick moment which misses clicks, makes right click view change impossible and is generally extremely annoying.

I’ve looked into opening ports and setting a static IP, but my ISP doesn’t allow that without purchasing an additional service. My attempts to set a static IP and open ports myself were unsuccessful.

Any tricks to get the game to stream the data without stutters would be greatly appreciated. Otherwise, I’m out of ideas.

Edit: Additional screenshots posted as replies due to limitation as new user.

EDIT 2: Another user found out it was a mod of one of the .json files for the Citation Longitude that was causing some sort of issue. After reverting the file to its original state, my stutter has gone away.

What type of hard drive is the game installed on?
The first time I installed it I accidentally put it on a spinning rust disk - very long load times and stutters. I moved the install to an SSD (don’t have room on my OS M.2 drive) and load times were much shorter and less stuttering.

I am assuming of course that the streamed data is written it disk before being used by the engine?

Having said that I am now suffering from different stuttering issues now but that’s covered in another post…

Have the same problem now, it just started yesterday evening. Sim was running smoothly before. Now freezes every 2 seconds for a short moment. This also appears in Menu. Only “fix” is to disconnect Server connection.

Is there any documentation or informed opinions about how the data is relayed from the MS server to the display?
For example is the data just buffered in RAM or written to disk first?
From what has been suggested on this post pulling the data connection stops the stutters (I will try myself later) so in theory it could be either?

I am using Samsung 970 EVO Plus 1 TB NVMe M.2 .Never had this Problem before. Also i didn’t make any changes to my System or the Sim.

Totally forgot to include that the game is indeed installed on a 1tb SSD. I run other flight sims from the same SSD with no stutter.

What I was curious about mainly was the ports required by MSFS and if opening them would help for seamless data streaming. I’m no networking engineer so I have no idea if that would help but it has helped me in other games. Because I’m unable to open my ports, I can’t test if that would make a difference. I also attempted to disable windows defender/antivirus and added the game to the whitelist with no impact.

See I don’t remember this being an issue a while ago for me either. Though I haven’t been flying every day, once I noticed the stutter, it’s all I can focus on atm. I also haven’t changed anything in the sim or my system. I did try rolling my graphics drivers back to the recommended driver but that didn’t help so I reverted to the latest driver.

The fact that I see no mention of it anywhere on this forum or other makes it seem like it’s a new issue caused by an update.

I am not sure it is update related because I took a 4H flight yesterday afternoon without this issue. I first noticed it the same day in the evening after I was a few hours offline. The Flight Sim don’t seem to have installed a new Update on my system. But it’s unplayable at the Moment for me :frowning: Maybe there is a Problem with the Flight Sim Servers.

Ok I found the reason for the issue. For me it is the Dakfly0219 Mod V1.51 of the Cessna Citation Longitude. After i uninstalled it everything is fine again. Never had problems with it before. Double checked and reinstalled it and
the Problem was back again.

1 Like

That’s crazy. I think I might have that installed as well. Will take a look tonight.

You, sir, found my issue as well! I took the mod out of my community folder but that didn’t help so I went into the asobo longitude files and reverted the .json file to the original and the stutter went away even with my data connection enabled. Thanks!

Your welcome. I also found out what I did wrong installing it. I created a copy of the complete asobo aircraft-longitude folder in the official onestore directory which seem to result in the Sim trying to load both files at the same time. Maybe you did the same thing? For me if I only create a backup of the layout.jason file everything is working fine.

I’ll check it out. What I think I did, IIRC, was made a copy of the original .json file and let the name the same except added “copy” to the end and left it in the same folder. There’s a chance the game didn’t like that but I’m willing to leave that mod alone to keep the game running well for now haha.

Yes Concur, this solved my stuttering, I was sceptical. but by removing said “Dakfly0219 Mod V1.51”, from Community folder, my stutters stopped.

Thank you
Regards Brian (BJ from Oz)

I m sorry, but this is not solved, it continue so mucht heave

Before creating a topic in the Bugs & Issues categories, assure no mods or 3rd party add-ons are installed per the guidelines of this section.

The purpose of the Bugs & Issues categories is to discuss issues that affect the base simulator (MSFS default content). Please do not discuss issues with third-party addons, or modifications in this category.

If you believe your issue may be caused by a third-party addon/mod, empty your community folder, restart the simulator and try to reproduce the error.

All issues caused by, or involving third-party addons/mods should be reported to the third-party developer. All issues related to the core simulator (MSFS default content) can be formally reported through Zendesk.