[Solved] Controls go crazy in Bell heli and aircraft carrier

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Only when i choole the Helicopter Bell or i choose the mission of take off the aircraft carrier , the controls go crazy. The throtle begins up and downd, the airplane and helicopter turns alone… if i change the plane and the map all works perfectly… it a shame because i paid for the heli and for the aircafraft mission…

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

Moved to #third-party-addon-discussion:tools-utilities as the common factor appears to be non-stock sim products.

Turn off assisted landings and takeoffs if you haven’t already. That will create that type of weird behaviour.

1 Like

I turned off assited landings and takeoffs, but still the same, now i have upoladed a video of the problem in the post… it only happens with this helicopter … and also in theaircraft carrier landing and takeoff
The video of the problem IMG_2905.MOV - Google Drive

Any one can help me?

Put your resolution down a bit or a bit from ultra to high and report.
For me this error occurs when the main CPU core has to work too much. No joke.

i ll try but i dont think so, because i change the map and works perfectly


am I understand you ok, if you select heli and also airport as standard Flight, all is ok? Then all is depended to some Mission or that situation you load. Can you describe better what is that? What version of sim? HW? OS? Only for sure to know…

No, ill try to explain me better.
I only have issues in this situations:
1- Anytime i choose the Heli bell.
2-Choosing the aircraf carrier.

In all other situations, MFS works perfectly

My fault…only have to ensure that all flight assists are set to Off … i did it and now it works fine… now i can discover new places in helicopter… thank yo all