[SOLVED]Object Appears fine in blender/3ds Max but messed up in the sim

Ive spent the last few hours troubleshooting this and simply cant figure out what the issue is. i exported a model from sketchup into blender like ive done hundreds of times by now but for some reason the textures for this building simply wont look right in the sim , ive tried exporting in all types of formats, used modelconverterX to minimize drawcalls and all that, the object only uses one texture anyways as it was originally made for Xplane .Any thoughts on what could be causing this? ive tried using blender and 3ds max to export but its the exact same issue.And the object looks alright when opened in the gltf viewer so i dont really understand why its only in the sim it appears like this when it looks ok everywhere else…help :sob: :sob: :sob:

Have you got the blender plugin for MSFS? If so I would use that to export to MSFS

yes thats what im using

what size is the texture??? It has to be a power of 2, it might be that.

Also is the texture a .png file, it has to be .png

If it looks ok in 3dsmax or Blender, and it looks ok in the .gitf viewer then it is the converter that turns it into the .dds file that is screwing up the texture, which leads me to believe it is not a 32bit .png file OR it is not a power of 2 size.

It seems to me the UV coordinates need amending. Are you sure the UVs are correctly allocated?

Have you tried baking the textures onto the model?

Are all vertices welded properly with no overlapping polys?

Thank you all for the help . @YearlingDeer319 thank you i didnt know why i didnt think of rebaking the texture once i got it into blender .After taking a closer look at the UVS they were indeed all messed uup,After i baked them again however everything looks good now .Thank you very much!


I look forward to seeing your work “in Sim”.

1 Like

Hi there, I’m having the same problem, my textures look fine in blender but in the simulator the textures are messed up. I’ve tried baking, but it’s still broken.
here is my model in blender:

and here it is in the sim:

Any ideas why this is happening?
any help would be much appreciated, thank you

It looks to me the UVs are not baked in properly in the correct orientation. Looks like the vertical UVs need to be properly scaled independently in the Y axis.

I use 3DS Max. I don’t know blender at all so I have no idea how you’d do this in practice.

1 Like

do you mean, I should flip or mirror the UV map? sorry, I’m quite new to the concept of UV maps

It’s easier to send you this link as it’s not something to give a quick answer.


1 Like

ok, I’ll have a look at it, thank you