Solved problem with self-installed liveries

Since the last update I can only fly with the standard livery of every airplane. I can see and select my liveries that I have installed in the hangar, but when I take a flight, I still only have the standard livery. I installed the liveries in the community folder. I bought the sim from the Microsoft Store.

Any help is appreciated.

Regards, Heinz

It’s up to the makers of the mods to provide updates to the mods on each patch.
It’s up to you to keep your mods up to date (especially the ones you’re not getting from the ingame store).

So yes, your liveries are outdated.

1 Like

Thanks for your answer.

I have the liveries from the Megapack. So do I have to look for the latest megapack after every Sim update?


Only after this update, hopefully. Livery organization has been changed with this release. @Neo4316 pointed me out to this link on a separate thread.

1 Like

This is all too complicated for me, so I am currently doing without additional liveries.

The main thing for me is that I know that the fault is not mine.


Just wait for the developers to re-relese them and they likely would’ve done it by now. I removed exiting ones from community folder re-downloaded liveries megapack and that worked for me.

1 Like

I removed the old liveries and downloaded a new Megapack (

Then I installed a few liveries and it seems to be working again.

Many thanks for your help.