Sound does not switch to a new device (headset)

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

NO

Have you disabled/removed all your mods and addons?

NO

Brief description of the issue:

While in the game if I plug my headset in to use as sound output, the game does not recognize the switch even if I then go to setting and change from default sound device to my headset. In order to use my headset I have to make sure the headset is plugged in before starting. When this fails I checked the Windows settings and they were correctly assigned to the headset and microphone so the game is the failure point.

Provide Screenshot(s)/video(s) of the issue encountered:

I can’t Its about sound.

Detailed steps to reproduce the issue encountered:

start a flight, plug in USB headset and mic.

PC specs and/or peripheral set up if relevant:

not relevant

Build Version # when you first started experiencing this issue:

SU12


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

It sounds like the game is not recognizing when you switch to your headset as the sound output device. Try plugging in your headset before starting the game to ensure it’s recognized, and if that doesn’t work, check for any in-game audio settings related to output devices.

Do you have the same issue if you follow the OP’s steps to reproduce it?

YES

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Tried various headsets and buds. Same issue with all.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

This happens as well when switching into VR. The sound won’t switch over to the VR headset but you have to start WMR first.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

This issue started with the latest update 12. I use PILOT2ATC and it correctly directs the sound to my USB headset when chosen as my sound output in windows but MSFS will only output to the external speakers. I find that if I start the game with windows directing the sound to my USB headset, that will work but MSFS will not switch from speakers to USB headset once the game has started even if I instruct Windows to change the destination.

If relevant, provide additional screenshots/video:

1 Like

Me too!
HP REVERB g2 headset. I’ve also noticed that volume change doesn’t have any effect.

1 Like

I’m noticing this with a Corsair HS80 wireless headset with USB transmitter. I’m also having this problem going both ways while in the sim. Whatever I start with, speakers or headset, I’m unable to swap to the other unless I restart the sim.

If I open the volume properties dialog box, it will show the correct output selected, but the sound meter will indicate sound routed to whatever the sim started with. For example, if I start on the headset, then try to swap to speakers, the sound meter will still indicate the headset is active while the output selection from the task bar will show speakers as selected.

1 Like

I found a workaround for this problem (at least it works for me) - turn off Active Spatial Sound in the sound options and then I get audio working.

7 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

YES

Provide extra information to complete the original description of the issue:

Workaround proposed by zvision78: I found a workaround for this problem (at least it works for me) - turn off Active Spatial Sound in the sound options and then I get audio working. ; will allow to regenerate output device.

If relevant, provide additional screenshots/video:

1 Like

This has long been a problem. If I start MSFS before connecting bluetooth headphones, it will not switch, even though they are now the default sound output. If you go into MSFS Sound section and explicitly select the headphones (yes, they are there), it still will refuse to use them. Headphones only work if I connect them before starting MSFS. Pretty annoying when you have to take a break and the headphones decide to disconnect. No way of getting them back after re-connecting.

5 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, exactly the same.

Provide extra information to complete the original description of the issue:

Happens with Bluetooth headphones also. Must restart the sim to get audio.

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes
Provide extra information to complete the original description of the issue:

No audio when switching audio devices E.g. VR or other devices (TCcA) that use audio via USB. Only relaunching the S/W fixes it (not exactly ideal mid-flight)
If relevant, provide additional screenshots/video:

can’t screen shot no sound!!

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, just the same

Provide extra information to complete the original description of the issue:

I have a normal headset/mic and Quest 2 VR headset. Whenever I switched device using the system tray volume icon it worked just fine. After SU 12 this no longer works dynamically. I have to start MSFS in the correct sound device for it to work. This means I cannot even use the VR speakers and mic as switching to VR in the game does not initiate a device change even if I manually select it.

If relevant, provide additional screenshots/video:

1 Like

Same issues here! No switching of sound output - nor on bluetooth speakers, nor on hp reverb g2.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

I have to manually change the input even if set to default or NVIDIA Broadcast. Setting them off and on consecutively without saving in between also fixes the issue.

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

OP describes issue perfectly. Even having all audio output devices plugged in and running before starting the sim, and default sound device selected in sim, MSFS does not use the currently selected device in Windows, only the one that was selected when MSFS started.

If relevant, provide additional screenshots/video:

N/A

My problem I believe since update 13 is my headset ATC no longer comes thru and is only heard on the speakers along with the engine sounds. The only sounds coming through the headset are avionics such as “Overspeed”. I use the Logitech G930.

Hi,
Since probably the last update, I’ve got this problem too…
Before, I was able to switch from speakers to headset and from headset to speakers as I want with no issue.
Now, impossible. And if I’m trying to switch, the game freeze and I have to kill it from the task manager…