Sound no longer working during flights 12/23/2020

Is your headset set as the default audio output for Windows? Not sure how changing an input would affect the output, and only some of it when the music and interface noises still work.

I’ve just run some more tests based on what you’ve just said. (Using the PA44 Seminole and EGMC as my departure airport each time to keep it the same).

Default sound settings = MSFS set to Sound Blaster Z (default)

  • Load MSFS, change sound card to onboard (not default) and carry on playing = Sound stays working
  • Restart MSFS = Sound NOT working
  • While MSFS is still running, change sound card to Sound Blaster Z (default) and carry on playing = Sound stays NOT working
  • Restart MSFS = Sound working

Bug report to be filed then…

In MSFS under SOUNDS, see if Spatial Sound is ON. If so, turn it OFF and see if that returns your sound.

1 Like

I set a sound input source in the Windows sound settings (i.e. headset voice input), then started MSFS and all sounds were available again. MSFS sound settings:
I have communication choices based on headphone simulation; Room sound image off

i cleared my community folder (even deleted it) and still no engine sound. I get ATC voices but no engine sound.

1 Like

Some (many) of the mods change the official Asobo configuration files for the default aircraft and add sound files outside of the community folder when you run their installer.

If you want to verify that the problem is with the default aircraft, rename the official aircraft folder and download that aircraft again from the marketplace. Shut down the computer and restart, then start the sim again, select the default plane, and see if the problem still exists. If the problem goes away, then the mod was responsible, likely from changing the official files.

2 Likes

Yesterday ATC sound go strange. I still hear my own voice, but the ATC either responds very softly or has no voice at all. I do not know what it depends on. I checked my voice settings, tried to change them, but no changes were made. The problem is with both Azure and Microsoft sounds.

I did this and reinstalled 172 classic and still no sound :frowning:

I did not have this issue before v1.12.13.0. I have always run the sound from MSFS on another output source other than the default. On the odd occasion I streamed, it meant only the audio from MSFS went to OBS and not system sounds etc.

I can reproduce the issue using the steps I posted above, 100% of the time (with and without addons in the Community folder).

This is how I got the sounds to stay working:

  • Run MSFS
  • Go to Options > General > Sound
  • Press F12 or click on ‘Reset to Defaults’ (Mine reset to the below)

  • Press F11 or click on ‘Apply To Save’
  • Press the Windows key on keyboard and type in Sound Settings, click on the result
    image
  • Scroll down and click on ‘Advanced sound options’
    image
  • Check that ‘Microsoft Flight Simulator’ is set to ‘Default’

    (I clicked in the top drop-down box next to ‘Microsoft Flight Simulator’ and changed it to something else then back to ‘Default’)
  • Close ‘Sound Settings’
  • Quit MSFS (I tried with and without rebooting, made no difference)
  • Run MSFS

The only changes I made after running MSFS again was some of the levels. i.e. Aircraft Engines and Warnings sounds down to 50%.

2 Likes

does the above fix work with addons in community?

I’ve had the same issue. In game music, but no in-cockpit sound.

Logged a call and told to update to latest Windows patch. Which I did and no change.

Emailed them back but since then radio silence, just like in the cockpit.

Clearly this is a wider issue than just my PC so why aren’t we hearing about a solution, this game cost a lot of money and the support seems to be lacklustre

1 Like

if you get a response from them I would love to know if it works, this is starting to really bother me!

Can confirm that this works.

I was also using a different audio output (for streaming purposes). While not ideal, I do have both UI sounds and menu music back, and in-game audio when using Spacial Sound.

The issue probably has to do with VR using a different audio output?

Hopefully they’re aware and do we get a fix with the next world update.

Yes, you are correct. I stumbled across this exact same “fix” and I no longer have a sound problem. Apparently the update changed a setting in Windows 10, as described above. Go to Settings, System, Sound, Advanced Sound options (app volume device preferences), Microsoft Flight Simulator and you may have to change speakers to realtek (even if that’s not what you are using), and device to default. This fixed my sound problem instantly.

works great! Just need to do it everytime I launch the game

1 Like

Yes I have a feeling it’s very much to do with the VR side of things.
I filed a bug report and it has been taken internally now, so fingers crossed!

Oculus Rift. The sound ONLY goes off when I click on VR mode?

@ExceededBull193, you’ll have to check the VR Section as I don’t (and won’t) have VR.

Hey, moin moin,

my Problem, in the Menu’s the Sound is normal. But if i start a Flight (Click on Fly), Loading with music…, and then there is no Sound from Weather or Engine or anything else. Only Menu Sounds there when on ESC Menu. In Options there is sound full.

Often the Ingame Menu with Setting for weather, fuel and co… is not there…
If I crash the bottom nothing happen… If i landed and shutdown the airplane, nothing happend.

Sorry for Bad English.

Don’t know if this helps anyone. But this same exact thing happened to me where I lost cockpit, engine sounds but could hear music and menu. For me it was the fly by wire neo mod I was using. Something happened with the files in the community folder. So I deleted it and loaded game and it works fine. Then I redownloaded the flyby wire and still works fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.