SPAD.Next Users - Hatswitch View Settings?

Using a Honeycomb Alpha and TCA Sidestick. On both devices, I’ve tried all of the online snipets and created new ones from scratch. For some reason, I can not get the hatswitches to operate any of the simconnect pan views, or other view commands. I can see that the commands are being sent by SPAD, but no reaction from sim. Every other button and axis configuration is SPAD I have works perfectly. Setting up these views in-game works perfectly, but just trying to keep as much as possible in SPAD. Am I missing something here on these hatswitch views?

1 Like

Could you post a screenshot of the bindings you have in SPAD? It’s difficult to suggest anything without knowing what you are trying.

These are the settings of one of the more downloaded snipets for Alpha hatswitches. I’ve also tried the “View-Up” Simconnect command with no luck, either. And strangely, can not get any of these view commands for either the Apha or 320 Sidestick.

1 Like

I’ll have a look later. I only use those functions using the sim bindings, rather than SPAD. But I can certainly have a play around with those events on other buttons. I’ll let you know how I get on.

Appreciate it. Setting up these views in-game works no problem on both devices. I must just be missing something on the SPAD config.

1 Like

I was actually setting up this exact thing last night, and found on the spad.next forums a thread indicating that in fact these events simply don’t work over SimConnect in MSFS 2020 right now – this appears to be a bug in MSFS.

Ended up putting everything except my view controls through spad.next, and the view controls directly through MSFS bindings. Seems to work fine this way so far; none of the view controls are always-pressed so they don’t trigger the dreaded “10-degree bug”. :slight_smile:

1 Like

Thanks for the feedback. I was checking the SPAD forums but all info there seemed pretty outdated, or I was just looking in the wrong spot. So for now, the solution is to re-map views in-game, no problem. At least getting closer to having SPAD run all commands. Crazy watching the event viewer with the default Alpha controls and all of the commands it’s constantly re-sending.

Yep, yoke, throttle, rudder pedals. All very chatty! :wink:

Could be a new form of Zen meditation. Hands, and feet on primary controls, and try not to generate any events in SPAD. Reminds me of the story behind the Amiga guru meditation errors.