Specific startup crash 50% of the time

My MSFS crashes to the desktop on startup about 50% of the time and always at the same place. The following are all of the relevant factors:

  • I am on PC - steam version
  • It happens randomly but about 50% of the time. I can successfully start it about 50% of the time (sometimes 2 or 3 days in a row) but other times it can crash multiple starts in a row.
  • It always happens just after I get the “Checking for Updates” screen. I see the little symbol twirl for a few moments as it checks for updates and then all of a sudden it will crash to the desktop
  • It happens whether I am in normal or safe startup mode
  • I have nothing in my community folder
  • Once it crashes, if I try it again it may crash or it may not… but eventually on the 2nd, 3rd or 4th try the game will start. I always get the game started… 50% on the first try and it has never taken me more than 4 attempts to eventually get it going.
  • My drivers are all up to date and it happens whether I start the game on a monitor or in VR.

This seems to be a very particular kind of problem…it is like it is trying to connect to or read something during or after checking for updates and that “something” is not available 50% of the time. But I am just guessing as I have no real idea what is happening. Thoughts and ideas are greatly appreciated,

I am seeing similar types of crashes. Interestingly, it seems to happen the FIRST time I start the sim after booting up the computer. I am operating a six-screen system with two supplemental screens actually active with MSFS 2020; the other three are acting as Windows only screens for pop-outs for the time being and only on occasion; not regularly.

The CTD seems to happen during the startup of the third MSFS screen. Following the CTD I restart the program, tell the program to use Normal mode rather than Safe mode and move happily on after that.

The system uses an AMD 5950X, RTX 3080TI, 32MB, six screens in total with three operational for MSFS. The others might run RealSimGear units and Air Manager. Admittedly, the system is heavily configured for the application, but the fact that it seems the CTD occurs at the initiation THE FIRST STARTUP, suggests a quirk in the experimental implementation of the multiple-screen functions.


Very interesting. Mine also happens the FIRST time I start the sim after booting the computer and, interestingly, I have never tried starting MSFS after another application. My flight sim rig is only used for flight sims (3) and I only boot it to go into one of the 3 sims. I will have to try some variations. For the longest time it would crash once after initial boot and then I, like you, would try Normal rather than Safe mode and all would work. But as you can see by my initial post I have started to get variations. But at the end of the day it always eventually starts properly in Normal mode… so it works, it just likes to crash a time or two to get there. I run a 3090, i9-11900K, 32B and Varjo Aero.
The only other inexplicable thing that happens on occasion is the following: After the initial Asobo screen and then the Blackshark screen, if my display goes black (and does not show any of the rest of the boot screens/graphics) it will ALWAYS boot successfully. If it shows the “Checking for updates” screen then there is a good chance it will crash right after it once or twice.