Spitfire - manual, battery switch, parking brakes?

Anyone know if you can map a Z-axis for the brake lever? I have a Virpil that has the Z on a lever. I use this for DCS and IL2. As of now in MSFS, the lever only works at the half way point. I have removed any buttons assigned to the Z-axis in Virpil config. So this does not seem to be a stick-config issue. I can also see in Windows game controller setup that the Z-axis works correctly. I should be able to very gently tap the lever and apply small rudder adjustments to control the aircraft, especially on landing. But, this does not work in MSFS, unless I am setting it up wrong … and ideas?

Not sure I understand. You mean using the parking brake (lever) during the rollout ? You don’t need it then and it would be lethal to use as it is a lever in appearance only but a switch in reality. Your aircraft would nose over.

Land at stall speed or close enough, keep the joystick or yoke fully aft until the aircraft is reasonably slow while controlling the direction with the rudder pedals, using your toe brakes by slight touches when you feel the aircraft is stable enough.

Dominque. Thanks for inquiring. I actually learned the Spitfire in DCS, and also fly it in IL2. The lever behind the stick acts as a parking brake when fully extended. After release, you use it to apply differing pressure, which triggers the brakes when you move the rudder. It is very effective. You can see the amount of pressure in the gauge. So, especially upon landing, you can gently tap the brake lever to softly engage the brakes, then, when needed, also, gently engage rudder right or left to brake slightly right or left. You do not use toe brakes. So, I am not talking about taxing, although you do need to use it when taxing as well, especially when forming up with other aircraft on the air strip and using a zig zag motion. So, the problem is that in MSFS 2020 the Z axis is not registering in the first half of the axis.

Hi Dominique, Redcloud111,

In RL the Spifire does not have toe brakes. The differential braking is performed as described by redcloud111. I have my toe brakes disabled on my pedals for the Spit, and have the joystick trigger bound to the brakes and another button to apply or release the parking brake in combination with the trigger. However, (redcloud), I have a problem in that even with full rudder right or left the pressure rises quickly on the opposing brake. This is not the case in FI’s X-plane version - brakes/pressure work as intended. Consequently, it looks like it’s not just the Z axis that is not behaving properly and providing the proportionality experienced in XP and DCS.

1 Like

Amiable. Yeah, toe-brakes have to be removed. I even tried to map the Z-axis to the left brake axis and right brake axis. What is interesting is that when doing this proper pressure can be applied with the lever, as seen in the gauge, but it applies it to both brakes! So, when you apply pressure and engage one rudder pedal to brake on that side it fails to brake on just that side. I have emailed FlyingIron to find out if the issue is on their end. If it is not, this is a bug or just something that hasn’t been implemented in MSFS. I am guessing the latter because it was an old WW2-warbird technology. Until they do this, I won’t be taking off or landing in the Spit …

Hi RC,

I, like you, would not be at all surprised if the issue was an MSFS deficiency. However, I already had an exchange of emails with Dan at FI, and he’s looking into it. Having to use toe brakes instead of the handle/rudder combination really detracts from the immersion, but I’m not ready to give up flying until a solution is found. Here’s hoping it can be fixed or Dan finds a workaround.

Thank you, I learnt something new today. I will look into that.

Hey, good know FI will look into it. I really can’t takeoff or land the Spitfire until they fix it. I have spent alot of time in DCS and IL2 with the Spitfire and have to use the lever/pedals combination, even though I feel totally comfortable with toe-brakes in a 109 or 190.

I have also contacted FI again. Still no word.