Standard barometric pressure not working on A32NX

I am using the stable version of A32NX. When I push the barometric pressure button at transition altitude, it does not switch to standard pressure. QNH29.92 keeps flashing on the PFD.

This is weird. If I click both the left and right mouse buttons at once, the setting will toggle between QNH and QFE. Then if I click the middle mouse wheel twice, it will change to standard pressure. However, these clicks do not always work the first time.

You need to switch to the Legacy Mouse user interface.

Great! That worked – thanks. It also fixed my inability to control other autopilot buttons. Something must have changed in the sim because I used to have this functionality.

I saw the option for “legacy” or “lock”, but the description said that the legacy was for mouse users exclusively so, since I have peripherals I didn’t think I was supposed to use it.

See the SU5 release notes. The new mouse UI was announced there. Glad it works now.

how can I find that?