Strange Artifacts post SU5

Now I really recommend to go back to 466.77!

My rig:
AMD Ryzen 7 3700X (with deactivated SMT)
MSI Geforce 3070Ti (upgraded from a 1660 Super) resolution 3440x1440

My story:
After upgrading from the 1660 Super I did a clean driver uninstall with DDU and installed the latest Nvidia driver. I was able to switch from low / medium settings to ultra and got some more FPS. Now, the CPU was the bottleneck. 2 cores at 100% while flying and the GPU arround 60%, 20-45 FPS.
With going back to 466.77 I have now about 80% on 2 CPU-cores and 100% at the GPU with arround 10 FPS more in every situation, even at JFK.
It looks like with the newer drivers Nvidia is offloading some things from the GPU to the CPU which would run more efficient on the GPU.

PS: Clouds are looking much better now

Does anyone know if this has been reported to Nvidia yet guys if its an Nvidia bug? If not maybe someone with existing screenshots should post over there? I’m also seeing this, its very distracting for sure.

This also resolves it for me.

Three things, latest driver, render scale above 100 and TAA - set to all those and you will get this issue, at least on a 3090

2 Likes

Just confirming something said on another forum: are all of us getting this issue with newer drivers using 1440 screens / resolutions? I am and I’ve seen several others are too.

1 Like

I get this with my Geforce RTX 3070, and running at 4K ultra settings. Render scaling 100 and TAA. It was all the time since SU5, however I still had some old drivers and after updating to the very latest 471.68 - it seemed to be fixed!

But then I did an LHR-MAD flight and upon landing in MAD - the issue returned! I don’t know why. I have since re-loaded into the sim at different locations and it seems fixed again with no other changes. So I don’t know what’s going on… What I do know is that this never happened before SU5!

I sure hope they are able to fix it, and I know lighting may be minor overall, but it really does break the immersion :frowning:

Download Nvidia drivers v466.77
https://www.nvidia.com/download/driverResults.aspx/176265/en-us

Uninstall Nvidia drivers and restart PC.
Install 466.77 drivers and restart PC.

2 Likes

Anyone know of an Nvidia forum / bug link for this. If not I guess they may never know about it if we don’t report it there.

Reminder for everyone to flag this with Zendesk.

1 Like

drat, I have been on holiday, and forgot about this issue, got home and updated to latest driver, the stupid artifacts are back. Time for DDU and roll back again!

Not sure. I think there was an Nvidia guy posting here a while back so hopefully they’ll stumble across this.

Bug seems to be fixed.
https://forums.flightsimulator.com/t/new-nvidia-drivers-471-96-whql-31-8-21/275276/786

1 Like

There was an Nvidia person posting in the forum a little while ago in the main driver thread. I think if I were him I would like to keep a low profile! :grinning_face_with_smiling_eyes:

Charles.

@TenPatrol @TheAviator3506

Can confirm the bug is still present with todays latest driver, sort of chequerboard artifacts at the top of the screen, especially when panning the view…

I won’t swear, I promise, though I am absolutely sick of this now.

1 Like

That’s disappointing. I can’t play one of my other games because of this.

@pidge2k could you kindly look into this? This is an issue affecting a lot of us with render scales over 100 running any driver after 466.77.

It seems the latest driver still does not fix this.

Any help on Nvidia’s side would be much appreciated!

I can confirm it’s not fixed - recorded the new bee gee r3 with the driver and it looked just as bad as su5 release day - back to 466 again.

In my case fixed.

Contact Manuel @pidge2k via e-mail driverfeedback@nvidia.com
Add dxdiag.
Also take a screenshot of your game settings and nvidia control panel settings.

I’ve submitted a feedback form to Nvidia and would encourage other users experiencing this to do the same:

“It’s fixed for me” is a toxic, trolling response to an actual problem other people are having (see multiple threads). If you don’t have the problem or a solution, we are better off with you not responding.

1 Like

Please read carefully.

https://forums.flightsimulator.com/t/strange-artifacts-post-su5/426969/54

Also please read …