Streaming MSFS in Discord only shows black screen

When trying to share the MSFS as “Application” in Discord it shows up with a black screen, sometimes with a thin border showing the sim contents but without updating, only the mouse pointer is visible. Not even in the menu or startup splash screens.
Sharing the “Screen” in Discord works and shows MSFS properly, it’s just if I select it as an application to share that doesn’t.
Did anyone have this issue before?

I tried all I could find online:

  • Updated NVidia drivers
  • Uninstalled Discord
  • Run Discord as Admin
  • Run MSFS as Admin
  • Disable hardware acceleration, H.264 acceleration, latest technology to capture,…
  • Kill all non-necessary background tasks etc.

All other programs show a picture, other games do too. It’s just MSFS that doesn’t work from what I can see.

Anyone had this issue before?

1 Like

Hey! I used to have your issue, for some time, I finally found the solution! Basically what I did on Discord is go to settings, voice and video, scroll to the very bottom, and select, “Use Windows.Graphics.Capture to capture a window on your screen.”

I hope this helps, I know this is late but you may have probably already fixed it. So for anyone else, I hope this helps!

Hey, thanks for the hint, I tried all the settings but the issue persisted.

The solution for me was to move windows of AxisAndOhs to my second screen. The moment I did that, Discord was able to stream MSFS.
It seems like AaO interferes with the way Discord captures the application.

So while your solution did not solve mine, thanks for the reminder to update this thread in case others face the same issue.

1 Like

You’re welcome and I glad you also found a fix. It’s quite unfortunate fixes may not always help, which lead to your issue and same with me.

But I am glad we both managed to solve it!

1 Like