Struggeling with my settings on a RTX4080 with a Gaming Laptop

I have a gaming Laptop with a i9-13900HX, RTX4080 and 64GB RAM
If I use DX12, NVIDIA DLSS Super Resolution (Balanced) and Frame Generation ON, TLOD 100 and the rest as a mix of Ultra and High I get a Frames above 120 ( idicated by MSI afterburner). But the frames jumping around between 60 and the 120’s. I’m not sure what is the optimal setting in MSFS and what I need to select in the Nvidia CP? (At the moment in the CP everything is default) I read a lot of entries here in the forum but most of them are related to a Desktop and not to a Laptop. The refresh rate of the Laptop is selectable for 240hz and 60hz so I’m not sure what is the best to choose.
So i really appreciate your input what settings make sense to have a more or less stutter free experience.
Thx in advance

The behavior is normal.

Ok but nevertheless if its “normal” i think there is room for improvements in the settings or to optimize the thing?

Why would you want more than 60-120 fps in a flight simulator?
On the contrary, I would increase TLOD to 200 to increase the terrain quality at distance.
Leave NVCP at default and reset sim graphics settings to the Ultra preset, see how it runs and take it from there.
There’s not much to fiddle with… people fiddle just to make Youtube videos hoping to become influencers.

Ok thx for the info. Maybe we missunderstand, I dont want more then 60 frames or more as this makes no difference. I just want to have a good and stable frame rate without sudden stutterings…but as you mentioned i then leave the nvidia cp as default without playing around. I read several times to set the AF to 16 in the CP and not in the sim and limit the frame rate in the CP as well…so you didnt suggest to make such changes in the CP right?

Yes, and take care particularly of the cooling to avoid thermal throttling… MSFS is hard for a laptop.
Also, better switch to DLSS Quality or TAA for better graphics quality.
To avoid framerate fluctuation you can set a limit in NVCP or RivaTuner.

I will try. Thx a lot !

1 Like

I agree.

With the FPS you’re getting I’d highly recommend setting DLSS to Quality as a minimum, I’d personally set it to DLAA. You will get much better graphical quality.

Some good NvCP settings would be to turn on G-SYNC, and switch off V-SYNC if switched on in the sim (if your display is G-SYNC compatible), another is to set a FPS cap to ~100.

G-SYNC will eliminate screen tearing and with lower latency than V-SYNC, and the 100FPS cap should help to smooth out some of the perceptible stutters when FPS fluctuates.

And as has already been said, I’d be looking at increasing settings while trying to keep a minimum of 60FPS(with FG), 30FPS without.

It sounds like when you get 60FPS you are CPU limited, there is probably a lot of GPU headroom to increase certain settings without lowering your FPS. This guide is very good and explains which graphics settings are CPU or GPU heavy! [HOW-TO] Graphics Settings and Performance Guide (SU12 Update) (7/26/2023)

1 Like

Do Laptops tend to have G-Sync compatibility?

@TBM9009319 Remember, too, a Laptop RTX4080 is not the same as having a Desktop RTX4080 (not that it’s bad, just be accordingly less expectatious).

1 Like

Mine does!

Newer Nvidia hardware gaming laptops generally do unless you get a budget gaming laptop. Any gaming laptop with a 4080+ should have GSYNC.

1 Like

Nvidia also recommends Prefer Maximum Performance for the power setting in the CP. This is supposed to keep your GPU clock cycles high. Might want to check your Windows power settings as well.

1 Like

Yes my new one has the possibility

1 Like

Thx I have set it already to max performance in the Nvidia CP