Stuck at loading screen (MSFS does not start)

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Yes

Brief description of the issue:

When starting MSFS, the app freezes at loading time. Two different scenarios occur, from one launch to another:

  • Complete freeze of the app at 50% (window is totally unresponsive, process must be killed). CPU and GPU at 0%
  • Partial freeze at 100% (doesn’t move but window remains responsive and closable). CPU at 0% but GPU almost at 100% in this case.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Start flight simulator :slight_smile: Secure mode does the same thing.
Note that several people have experienced the same issue at the same time, see Can't get the Main menu screen - #6 by blancbonnet

Many issues may be due to an outdated graphics card. Please state your Graphics Card Driver Manufacturer (NVIDIA, Intel, AMD) and Version:

Gigabyte GeForce RTX 4080 16Gb with latest driver installed

PC specs and/or peripheral set up if relevant:

Windows 11, Intel Core i7-13700K, 32Gb RAM, 4 screens

Build Version # when you first started experiencing this issue:

latest stable

Hi @EconomyArc31614 ,

We’ve moved your topic into the User Support Hub.

The Bug Reporting Hub is for posting suspected or confirmed bugs that other users are able to reproduce without duplicating an existing bug report. Using the template or providing all the relevant information about your bug and sim setup is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the User Support Hub category. If the community can replicate your issue, first search the Bug category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report and no duplicate exists, then create a new bug topic using the provided topic template.

All issues caused by or involving third-party addons/mods should be reported to the third-party developer. Assure that no addons/mods are used when reporting issues in Bug Reports.

1 Like

Dear @DementedCorn327,

Thank you but I don’t understand why the post doesn’t qualify for the bug reporting hub as:

  • it is actually replicated by several users (see provided link)
  • it is reproductible without any third-party addon or mod
  • I carefully filled the provided template
  • I wan’t able to find an existing bug it would duplicate

Moreover it is critical as the product doesn’t even start.

I am Also stuck on loading screen, music still playing though. Stuck on Dune flash screen with blue bar at full.
I have re-installed msfs 3 times now (which takes 24hrs, plays for a week then back to Dune screen).
Windows 11. pro
12th Gen Intel(R) Core™ i5-12600K 3.70 GHz Boost 5 GHz
32.0 GB (31.8 GB usable) DDR 4
NVIDIA GeForce RTX 3080
Samsung SSD 980 PRO 1TB
PC is stable with no issues, I play msfs in optimised version via nvidia

Is there a solution as MSFS is not playable at present.

I’m probably being dim but how would I reproduce it?

I understand what you mean, I work in the software industry and I know a little about bug reporting.

As a matter of fact several people can reproduce the exact same problem simply starting the app.

Of course there might be some sort of particular circumstances for this to happen, but I seriously doubt they are proper to the involved configurations as the problem appears and disappears without changing anything.

Actually the problem disappeared after an update this day. Didn’t do anything beside powering the PC on and running the app…

I think there should be a minimal journaling of what happens behind the scene otherwise we cannot investigate anything even holding a PhD in Computer Science (and I do).

Thanks (don’t know who) for the fix anyway :wink:

You need to repair Gaming Services on your PC using the Xbox App:

  1. Launch the Xbox app for PC.
  2. Click your Profile picture.
  3. Click on Support.
  4. Click on Gaming Services Repair Tool.
  5. Click on Start repairing.

This takes about 30 seconds on my PC and fixes the issue until next time it happens, usually after a CTD.

Thanks @GBTAW, I’ll try if the problem occurs again.

This time I just got had to reconnect (for the 50th time) to Xbox, then I got an update of the sim, and then it started flawlessly

2 Likes

Glad that the sim finally fully loaded. That issue can have multiple root causes based on individual user configuration and can be fixed by following some steps I have posted in another post (see below). Since it is not a direct bug within MSFS, this is why all similar reports are moved to the User Support Hub and users advised about existing troubleshooting procedures.

To GBTAW
Tried your suggestion re repair via XBox App.
Still no Joy.
I will uninstall and leave for a while.
I think it is sad that this happens as MSFS is not a cheap (Game/Sim).
Plus it takes 2 days to load everything again.
I use the Hype H160, rarely planes.
I can load, play anything else, it is just MSFS that has an issue.
And I am not alone, others have same issue.

Also having this problem 5 clean installs of msfs and a clean windows install, chasing every fix and workaround on the internet for the past 2 weeks… pretty much ready to give up on msfs unfortunatly…

Before giving-up try one more time the following procedure I’ve found here in the forum .It worked in my case. First of all make sure you have updated Windows…

GaunerKobra5824

Toro360720

7d

This I have done ,
UPDATE GAMING SERVICES AND RE-ENTER YOUR CREDENTIALS

Open the Microsoft Store app on your computer.

In the bottom left corner of the Microsoft Store, click on the library icon

In the top left corner, click “Get Updates” then "Update all" and wait for the updates to install.

Once the updates are installed, click on your profile icon in the top right corner of the screen.

Under your email address, click on "Sign out".

Reboot the computer

Open the Microsoft Store app.

Click on the icon in the top right corner, then click on Sign in.

Sign in with the Microsoft account you used to play Microsoft Flight Simulator.

Start the Sim

Tried that GaunerKobra5824 still no success
I know when is stuck due to blue loading bar taking ages to reach R/H side

I f games loads the blue bar moves at speed.
If I play msfs every couple of days works fine, if I leave for a week, gets stuck and does not load. Community folder empty makes no difference.

I repeat, I am not the only person with this problem and Microsoft need to sort this as they take a lot of money from you.

@HELIMEDIC57 ,
Hi, sorry to hear that you are still having issues.
There was another update to Gaming Services recently (May 10th on my PC) . If you have not already done so, check that it has been updated by Opening the MS Store, selecting “Library” and clicking on “Get Updates”. Also update any Xbox apps that need updating too.

Just to confirm - you completed the steps outlined by @DementedCorn327 in this post, right?: