Stuck Decompressing a file

When downloading the game, i made it all the way to 300Mb remaining. Then suddenly the download just stopped progressing and has been sitting on “decompressing fs-base-cgl-0.1.6.3.fspackage.004” for hours. I have tried deleting that specific file and it just got stuck on a different one. I also tried completely reinstalling the game and here we are again. If anyone knows how to fix this I would appreciate it.

gtx 1060 6gb
ryzen 3700x
16gb ddr4 ram
1tb ssd storage

Microsoft store version

Also it should be noted, I have played this game before without issue, but ever since reinstalling it I have had countless issues with this installer.

Hi @flyby7,
Welcome to the forums.

Have you looked at other topics on decompressing?
Search results for ‘decompressing category:200’ - Microsoft Flight Simulator Forums

There is also a FAQ:
Download stuck on packages / Install loop & Decompressing issues – Microsoft Flight Simulator Support (zendesk.com)

I cant really find anything here that i haven’t already seen or tried. Nothing seems to be fixing it.

Unfortunately it’s reasonably common that you have to keep repeating the process of deleting the stuck files and continuing. Providing you keep doing that when it gets stuck, it will finish eventually.

I know that’s not much comfort, but it will work.

1 Like

Thanks for the response.
Is it normal that after I delete the file and relaunch the game, i’m back at 48gb remaining?

It will have to redownload parts of the update when you delete those files, so quite possibly.

Alright thanks. This is my 5th time deleting files and redownloading so hopefully it will finally work. I really wish this game could download through the microsoft store or steam, instead of in game.

3 Likes

Hey, something that worked for me was after uninstallig the complete game delete the Microsoft Flight Simulator folder in AppData/Roaming and then install the game again hope That Helps

Under appdata/roaming, there is no flight simulator folder that I can see at all. (after I have uninstalled from apps and programs)

Something that worked for me was creating a new build/load of Windows 10 as opposed to using Windows 11. I was flying even in the Himalayas and couldn’t get it to fail, it was failing 100% of the time trying to do ANYTHING much less fly the Himalayas. It would get stuck on compressing, but the number of memory errors in FS2020 and Forza 5, just would crash or come up with the memory error 0xc0000000005, etc, etc. I could not get around it with anything, and I tried all the supposed fixes and corrections and settings

This is honestly ridiculous. Getting toward 2 years after release and the bloody installer still doesn’t work. And then once you get the thing installed the game is full of bugs, so you have to do a full reinstall to troubleshoot that, and deal with the bugged installer again… what a joke.

Same thing here! I recently formatted my computer and I can’t reinstall FS (From Steam). It starts to decompress and suddenly it stops. I have tried deleting the AppData multiple times but it has not helped. It starts updating and randomly in the middle of the update it stops. I have to go to Steam and Stop the app. I even tested installing the updates on another folder that I created, but nothing. One thing to note is that it always hangs when “decompressing” a file.
System is:
Ryzen 7 5800X
64GB
RTX 3070

1 Like

Adding one more detail. I found a way to proceed with the installation. Once the install hangs, I stop FS, delete the .fspatch and.fspackage files and restart the install. Slow (like VERY SLOW) but at least it works.

1 Like

I’m having the EXACT same issue(s).
Now I can’t fly - seemingly forever.

Also, FS2020 ‘automatically’ starts downloading content in your Content Manager - before you get a chance to manually select. So when you do delete the ‘failed to decompress’ file, it’s already started and hey-ho, it hangs again.

I can’t believe nobody, particularly Microsoft, haven’t got a solution for this common issue.