Stuck in Camera Mode, Cam Menu unresponsive

I just got stuck in external view mode after clicking “showcase” via the camera menu [VR mode].
Nothing I tried brought me back into the cockpit. Check my key bindings, opened the toolbar, clicked the camera menu… nothing worked.

I could click the camera menu but the window didn´t pop up. The button was highlighted though…
I had to exit VR mode to even get the toolbar working, the camea menu popped up but any menu or option I clicked just didn´t respond.

The response to any keyboard or controller input was simply switching between the external side and back view…

When I tried to renenter VR mode, nothing happend… just saw the SteamVR room.
Had to force a shutdown via taskmanager to get out of this!

I´m starting to get very angry with MSFS… not once there was a day where I could simple get into a plane a have a nice flight, something always goes wrong… :face_with_symbols_over_mouth: stupid public beta testing! :wink:

Does anyone know a fix for this “stuck in camera mode with nothing working”-issue??

Many thx!

The END key should get you back to cockpit view.

Yeah… I know, and I pressed it… not just once!
As I wrote, I pressed every button that should change camera or cam-position and nothing worked…
Checked the bindings, “END” is assigned for cockpit.

I use Voice Attack for my camera views and I also somehow selected showcase on the camera menu and was stuck outside the cockpit.

What I found for me was instrument view 3, 4 or 5 got me back inside the cockpit and then instrument 0 put me back in my correct position to fly. For some reason trying instrument 0 from outside did not work to get me back in the cockpit.

Alright, thanks for the tip! :+1: I will try this next time I get stuck outside.
Did you use VR Mode when you got stuck?

I saw the key bindings for those views when I check the cockpit binding but I didn´t occur to me, that they would even work outside the cockpit…

Yes I use Voice Attack inside and outside of the cockpit.

Before I have my headset on I say “VR mode” to put MSFS in VR mode with the only stipulation that MSFS has to have focus to accept the commands.

1 Like


I just use my Index but I have a bunch of Logitech Panels. So far they work quite well with MSFS and many cockpit functions are covered but I will check out Voice Attack too!

I hope, I find some time this weekend to fly and to see if I can reproduce the “getting stuck outside” issue and if your workaround works for me too!

Much time has passed but if anyone else gets stuck like this; I was trying every key and combination to no avail, then I pressed the 9 key and my view moved down, then using the number keys I figured out I was in SLEW mode. I looked at the keybinds for slew mode and the key command to exit slew mode is “Y”. Presto, I was back in the cockpit. Good Luck.

1 Like