Stuck on black screen due to audio output device

This problem has affected my sim since launch; no fix yet.

The audio output device I normally use for my speaker/headphone output is Speakers (Realtek®); however, if I have that or any other audio output device than Speakers (Sonic Studio Virtual Mixer) selected in Windows as my output device, MSFS will show the black screen with a loading icon but is then stuck on the same black screen, no loading icon, and never proceeds to the intro/logo animations.
Setting the audio output device to Speakers (Sonic Studio Virtual Mixer) solves this, but then I have no sound (as soon as I’m in the MSFS menu I can change to my actual output device and sound is restored).

Anyone else experiencing this?

Haven’t reported the issue on Zendesk yet, wanted to ask here first if there is a fix for it.

Thanks in advance!

Hey SnekPitTom,

I have never had any problems loading the sim, until a few days ago. Tried everything I could find, but I never thought to check the audio device output. Reading your topic just now, I gave it a shot, and changed it from the speakers (which I like to use for regular desktop use) to my headset (which I usually - though not always, incl MSFS - use for games) and somehow, it did fix my issue…

As I have run MSFS on my speakers before, I started thinking about what could’ve changed between the last time my sim ran fine and it failing to load, and the only thing I could think of was me installing Twitch’s Soundtrack Beta last Saturday. I just uninstalled that, and now, I can run MSFS again on any default audio device I like.

It may not be Twitch’s Soundtrack for you, but it sounds like something (hard- or software) that creates a (virtual?) audio device might be interfering with MSFS. In your case, I’d look at that Sonic Studio Virtual Mixer first.

Maybe it’s a general Windows issue and other games are affected too, but I haven’t checked.

1 Like

Yeah I had this issue recently after an update of NVIDIA drivers.
Had to switch the sound output device, and all was good

1 Like

Thanks @BVTEagleEye and @ATPL2006 for your replies.

Did a bit more digging this morning and found the following two resources:

This post from Microsoft on Zendesk mentions that there can potentially be conflicts/issues with certain other software. Sonic Audio (still unsure where this comes from) is on that list.

This video on YouTube, which brings up an interesting point that it may be related to which output device was selected when MSFS was installed, although he mentions a reinstall - with the correct output device selected - did not fix the issue.

@BVTEagleEye, it is quite interesting that uninstalling Soundtrack Beta fixed it for you. I will definitely have a look through my apps to see if any could potentially interfere with MSFS booting.

I’ll post here if I come to any conclusions - I hope you will do the same.

It seems to be a more general problem, not only affecting MSFS.

I just reinstalled Soundtrack for testing purposes and am now online as VATSIM ATCo, where I initially couldn’t hear pilots over AFV. Uninstalled Soundtrack again, and … fixed.

Short update:
Tried uninstalling the Speakers (Sonic Studio Virtual Mixer) audio device in Device Manager; this did not fix the bug, and I still have to select an audio output device different to Speakers (Realtek®) in order to advance from the black screen to the logo/splash screens.

SOLVED:

Played around with audio settings since the issue seemed to be related directly to the audio output device, and happened to find the fix for this issue.

To fix the sim getting stuck on empty black screen before any of the logo splash screens, go to Settings in Windows > System > Sound > Output > Device properties > Spatial sound format, and if it is set to Off, change it to Windows Sonic for Headphones.

As soon as I did this I could boot the sim without having to change my audio output device.

Can @ATPL2006 and @BVTEagleEye confirm if this works for them?

Link to Zendesk bug report here.

For any future reader, I hope this fixes the black screen bug for you.

Have a great day :grin:

3 Likes

I will give it a try but I didn’t face this issue anymore since I changed the sound device, this is when the sim started, then while being in the sim i changed it back. Restarted the sim, and all is good.
I will try to change to another device and see if the sim freezes again. Then I can check your solution.

Thanks for sharing your finding with the community !

No problem @ATPL2006. It fixed this frustrating issue for me so of course I wanted to share the solution with other simmers. No more changing audio output device since I changed the setting mentioned.

Do report back when you have tried it too.