Stuck on cessna loading screen, won't load after previously freezing while plugging controls

I loaded the sim and realized I didn’t plug my yoke (Saitek yoke,pedals and throttle). i plugged them in and chose to keep the default profile. After a few seconds the sim froze, couldn’t alt+F4 so I ctrl+alt+del the process.

Now the sim loads to the main menu but everytime I try to launch a flight it stays on the screen with the Cessna at about 60%.

Tried the troubleshooting steps on zendesk to no avail and it doesn’t make sense that it just stops working like that.

I also tried repairing the installation and it didn’t work. Community folder is empty as well.

Anyone had a similar problem or can shed some light on this?

also if you choose another airplane ?

EDIT: if so, you can try to delete the customflight…flt

Thank you it looks like the developer mode might have been the problem.

oh yes… you should not use the developer as “always on” … there are lot of users which then report issues. Please use it only in case you search an issue / perf-issue / etc. and then deactivate it again :slight_smile:

1 Like