Stuck on flight loading then CTD

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
MSFS gets stuck on the flight loading screen. If I wait long enough, it will CTD without an error message. In the event viewer I find this line: “Exception code: 0xc0000005”. I did manage to finally get a flight to load. I reset and repaired MSFS. Restarted the PC. Emptied the community folder. Started a flight without online services: that worked. Next step I put the Kodiak in the community folder. That also worked. But no idea which one of these resolved the issue. And I had many successful flights yesterday, and didn’t change anything from the last flight yesterday to the first flight today.

Provide Screenshot(s)/video(s) of the issue encountered:
N/A

Detailed steps to reproduce the issue encountered:
Load a flight.

PC specs and/or peripheral set up if relevant:
12900KF, 3090, 32GB DDR5

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Are you using DX12?
No

Are you using DLSS?
Yes


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Ive been getting the same thing, the secret seems to be just keep loading the sim eventually it will ‘catch’ ;p

Theres a thread about that error, if I remember correctly they had you exclude everything MS, and disable what was left. Of course if your on Steam, it kills that and a bunch of other things needed to run. And if you enable just enough to get it to run, it will still crash. Its like a big game of simulator roulette, will you get lucky this time and get it to run, will you be able to switch windows in and out to get HD working without a crash… PLACE YOUR BETS!!! Bwhahahaha

Hmm yeah. Maybe I got lucky on my xxx attempt and none of the things I did had anything to do with it. Could have just been pure coincidence…

I had the same problem a few days ago. After several attempts, I got a message asking to allow MSFS in the firewall. I check the firewall and everything looked normal. I went through the process of blocking and then allowing MSFS. I don’t know if this was the problem but it worked after that.

The event log also has this:

Faulting module name: VCRUNTIME140.dll, version: 14.30.30704.0, time stamp: 0x615a9215

Does that mean I should install my C++ redistribution packages?

Does the freeze happen at half of the loading process? I have seen that since beta 17 several times this week.

Cheers

No, it gets all the way towards the end, perhaps 70-80% or so, then freezes.

You could try, but I think you’ll find the same thing after reinstalling, sometimes it will work and sometimes it wont.
Mine was complaining about a corrupt dx11 error, so I did a dx diag, and guess what it found nothing wrong. And nothing was fixed.

Yeah I managed to load into (and finish) a couple of flights today. One in the Kodiak and another in the analog Caravan. Not going to make any changes on my system as the issue seems quite random. I’ll just wait and see for now.

I just loaded into a flight, 26 fps, but no HD, so I do the window trick and as soon as I window out BAM! 9 fps. Went back to full screen but it never recovered.

So Im playing Eve Online today…good thing I saved the booster from the other day!

Yeah. I’m playing civ with my daughter :slight_smile: Need to take a break from this sim for my sanity’s sake.

1 Like