Stuck on loading screen, 2 Weeks of Troubleshooting Help!

Maybe one question.

At what % / position *or give screenshot) it hangs? I feel that in case of cca 3/4 there is something related to graphic card, I hear something at my rig like that. As you said that old HW is ok then it is clear now. At my hands, I’ll try set at BIOS all to AUTO (DRAM,…) to see. Is any chance you try other graphic card at your new PC?

So since last reply ive verified my game files are fine as i transfered ssd to other PC, downloaded the installer, pointed it towards the msfs ssd… and i was off flying… put it back on new pc and froze. I checked event viewer for error logs and found a 1000 & 1001 errors that crash the game… which is the same error as DXGI_EROR_DEVICE_HUNG…
Issues tend to be:
-Drivers (tried so many drivers, studio/game versions also + DDU’s.)
-App bugs
-gpu overheating (temps barely get about 60)
-gpu overclocked (only factoy OC… even tried underclocking to reference and power limit)

I can pretty much rule all of thoes issues out… so im not sure what it is… surly its not the gpu… i could be wrong but i play other games fine at 240 fps 1440p and handles stress test fine

Ill try the 5700xt in new pc… i cant swap ram or mobo or cpu as all are different. And not sure if i can put 4090 in old pc as only 750w psu

This is what I mean. But try look at XMP in BIOS but take care to do steps logically and to have not mixed things wrongly. Do for first some HW swaps. If it will work somehow, try that BIOS AUTO/XMP careful cfgs with your 4090 then. I’ll be not surprised that AMD gpu will work on your new system but expect drivers install/cfg so do also restart of PC for sure. Good luck to find the problem.

Although if i change gpu to amd, it doesnt rule out the driver error possibility. Here is the error i get and where blue bar freezes

1 Like

At my hands,

BIOS - AI AUTO set where you can test this and DRAM XMP set to some better option. If that fails, really I can say Motherboard but you know, we can speculate. As first and important is that your previous HW is ok, here start the investigation…

I don’t know now, something also says to me that Authentification can plays role here. Meanwhile, there is post with KNOWN ISSUE tag so I don’t know exactly, to which account and machine your sim is related. Also here investigate after that. I had some worse problems in history - no game at my disk but 2hr before all was ok, you know all is about system how sim is prepared. Good luck and post pls some news, hope some one will have idea after some your findings.

Item 1 on the error list is “driver fault”. Have you tried uninstalling the driver and then running MSFS?

Since you have an i9 1300k, one way you could quickly determine if it is a problem specific to the Asus RTX 4090 is to temporarily plug your monitor into one of the Integrated Graphic Chip ports. If you get past the DXGI error to the Welcome screen, then you know the problem it is related to the RTX 4090.

You may need to go into the MSI BIOS and enable the IGC, depending upon what the MSI defaults are for the z790.

w.r.t. your comment on Starlink, I use that service too and have not had any issues with it.

So ive been testing alot the last few days. I pulled 5700xt out of my old pc and put in new pc, MSFS booted up fine no troubles. Put 4090 in old pc, same dxgi_error_device hung. Loaded up 3d bench mark and ran firestrike. Finished with a score of 47k ran DCS on old pc and worked perfectly… is my 4090 toast? Or is it just not compatible with msfs?

Wait!

This is different now to your previous situation, so what has changed?

Then this is looks like problem of drivers (MB/GPU) probably. Pay attention to think what you did so your AMD now is working on new PC.

I did nothing absolutly nothing when i installed 5700xt into new system, besided i did DDU the Nvidia driver and installed AMD adrenilin software and installed latest driver… launched msfs without touching any settings… works… exactly the same deal with 4090 in old system but same crash… but will benchmark and run other games fine. Has to be software reated right? Some sort of incomatibility or defult settings somewhere i havent tried :man_shrugging:

Will swap gpu’s back over and start digging through settings and drivers lol

1 Like

Old pc is a completely different rig, amd 3700x ddr4 ram instead of ddr5. Windows 10 instead of 11… 750w psu vs 1000w… so lots of changes but same dxgi error and event viewer id 0

UPDATE- i got into the game with the 4090 but i had to set the ingame setting with other pc to as low as possible, and ingame frame rate setting to 33% of my monitor refresh rate and I had to lock my 240hz monitor to 60hz, so essentially in game fps was locked to 20 FPS… was exited when i loaded in and could (very slowly) click around the menu. As soon as i changed the frame rate setting to 50% monitor refresh rate… game CTD with DXGI_ERROR_DEVICE_HUNG. It has to be a setting somewhere im missing in either windows, bios or Nvidia… i got no idea lol

1 Like

I don’t know,

VSYNC parameter at your side? Properties on Nvidia Control Panel also?

Ive got everything turned off in nvidia control panel including vsync. And fps set to under 20 fps its the only way i can load the game… otherwise it drops the nvlddmkm component and CTD with device hung msg

Then only Zendesk report, with all documented screenshots you have. Good luck.

Ok, new update… i dont think this issue is directly related to msfs (for my case atleast). The reason i come to this conclusion is that my pc wont run timespy on 3dmark either. Loads the benchmark but stutteres and software freezes with same nvlddmkm error. But then i load up heaven or firsestrke on 3dmark and it runs fine. Time spy is a dx12 benchmark and fire strike is dx11… but i have the trouble in msfs in both dx11 & 12.

I’ll be not helpful here further, I see.

Just I’m curious, what exactly brand 4090 you have? Any closer deep internal firmw infos from driver/Nvidia panel can be maybe helpful for others.

As soon as the loading starts to slow down, use CTRL+ALT+DELETE to change USER. As soon as you log on again, the game screen will be there. (I hope)