Stuck on the "Checking for Updates" screen while the game tries to install

Hi all.

I hope some can help me please.

My MSFS 2020 (Steam Version) has been running perfectly until last Tuesday (7/2/23) when it suddenly decided to get stuck on the checking for updates screen. I have never had this problem before. I left it checking while I popped out for half an hour and when I can back it told me that it wanted to reinstall the game. I was perplexed but did what it said and reinstalled it, the game worked perfectly. I tried it again on Thursday evening (9/2/23) and it wouldn’t load, it was stuck on the checking for updates screen again. The sim was on a seperate drive to my operating system, so out of sheer desperation I have formatted it. I have also formatted my C drive and reinstalled Windows but I still have the same problem. The difference now is that Steam has installed the initial 2GB of files, but when I press Play it launches MSFS and then gets stuck checking for updates so it won’t even allow me to intsall the game files !!! I have tried various things, from running as Administrator to unplugging the Ethernet cable to get it to skip the checking stage. I am at a total loss as to what to do to get out of the mess that I am in, I just hope that someone has some idea of where I go from here to start flying again.



1 Like

Hello @Geonet,
Assure that Windows is up-to-date as well as the MS Store (even though you have Steam). Manually check for updates and then restart your device (restart, not shut down - even if there was no updates).

Don’t run as Administrator as this can cause further issues.

Hi @Hester40MT
I have tried everything you suggested and it is still stuck on checking for updates.

I recently discovered that if I have Little Navmap running before I start the sim then the sim can hang during loading, like when it’s looking for updates. So now I only start LittleNavMap once the sim is fully loaded and it’s all fine.

Hi. Yes I have the exact same problem this week, especially after updating Windows?

The users replies so far have been no help?

1 Like

Started getting same issue this week. Can’t figure out solution.

Well, I’m also stuck on “checking for updates” and tried nearly everything suggested:

  1. reinstalled network drivers
  2. emptied the community folder
  3. deleted rolling cache
  4. deleted .fscontent file
  5. repaired MSFS installation

Nothing solved the issue!
The only way to get past the update check is to disconnect the network connection while loading. After that MSFS comes up even with a filled community folder.


Try removing the Reno Air Races and Reno Aircraft Class packs. That worked for me.

Also try temporarily relocating purchased addons from your Official folder (including aircraft addons). It is not just the Community Folder. The Official folder scenery addons count towards the file limit (about 1250 files - liveries apparently count). I have purchased over 650 addons via the marketplace and I can now only play this game (with those addons, chosen liveries, and freeware) if I use Addon Linker to load only the area addons I intend to use per session.

Do NOT relocate anything from the Official Folder labled “Asobo…” , “Microsoft …” or " fs-base …" The game will see it as needing an update and pronpt you to dowload files when you start MSFS.

NOTE: I suggest TEMPORARILY RELOCATING because having to fully download everything had become a 1 week chore for me after each sim update and clean install. Addon Linker allows you to unload all or some of your purchases at a click of a button.

Sub NOTE: For me, I still think MSFS is the best gaming entertainment EVER.

Has anyone contacted Zendesk about this to report it? The limit seems to vary all over for me depending on which addons. It seems arbitrary and random and only started after after the New Zealand update. Addon Linker is not a great solution for me because I often choose semi-randomly where I want to fly. I don’t want to have to reload the entire game just to get a few different airports loaded in.

I finally managed to get round the issue. I have a VPN and I set it to another country to where I am, and it finally loaded. Recent sim update seem to have sorted the problem for me so I no longer have to use the VPN !!


i HAVE THE SAME PROBLEM RIGHT NOW FOR AN HOUR… how do you change the VPN? to try it


Having it today while loading game, after whole summer without it. Not a good sign at all. I just hope this pain in the butt does not come again…


1 Like

A LOT of weird things going on with the sim at the moment. Stuck on the “checking for updates” when trying to load up the sim. Tried 4 times. Then it worked.

But now I cant load a flight from map-view to runway. Its…stuck!

Any ideas whats going on? Using EU-servers btw…

Just change your VPN to a different country than your home country. I am in the UK and I changed my VPN to Germany and it loaded !!! I’ve no idea why it worked, but my sim has loaded fine without doing this for the past few months.

I’m stuck at checking for updates too, never happened before, any ideas?

Same issue here. Disabling my ethernet and wifi adapters until past the update screen seems to work.
I wonder if this is a server issue. Game waiting for confirmation that never comes.

Random observation: The game logo screen that you typically only see a safe mode message on becomes the loading screen. Apparently the normal loading screens or generated online??

Experiencing the same thing. Stuck on the “Checking for updates” screen . Only way to get passed it is to disable network until it gets passed it.

I have experienced the same issue a minute ago. I have tried a couple of times but it got stuck solid

1 Like

Same, was in game and it CTD, first time in forever and now stuck checking for updates