Stuck on the Loading Page after UK updates [FIXED: Bing Map Load issue due to system language]

Hi,

I’m having super annoying issues with unable to load any flight or challenges ever since the 24GB UK updates.

The game will be stuck at 30% of the loading bar and won’t progress further. even if left on for hours.

Tried and failed:

  • Re-install
  • reset graphic setting to lowest possible.
  • Full Screen, update drivers etc.

Can someone please help and share if you have the same issue pls!

-----------------SOLUTION FOUND-------------------------------

Community Power!! Thanks for the input of @MachSystems and @Lyvshalker . We have found the solution on this pretty unique issue:

Solution 1 (Temp fix): In-Game: Turn Bing maps off in Options->Data. It will disable the Bing Map and enabling the loading of the game.

Solution 2 (Best solution): If your Windows system setting is coded with non-English language, it will cause the glitch. You will need to change your system’s non-unicode setting to English. As shown in the pic below.

Hi @ZephyrFan,
Did you check the Content Manager to see if there were also any updates in there? Also, don’t put anything back in “Community” (if you have add-ons) just assure it’s nothing there causing a problem.

I wouldn’t let it sit there loading for hours. If it doesn’t load in max 10 mins, there’s probably a problem (either slow internet connection to server or other issue).

Same here, tried everything, still didn’t work

Try turn Bing maps off in Options->Data, at least it works for me.

Hey thanks for replying. Yes, i have double-checked the community forlder are empty. and content managers are all up to date. The issue still persist.

Thanks to @MachSystems , it worked perfectly after switch BING off.

Thanks for the reply! I am currently re-downloading everything :joy:, will try it later.

1 Like

Thanks, it works perfectly!

Most of the time, re-downloading or reinstall won’t solve any problem, just waste of your precious time.

Meanwhile, the download and reinstall process is long and painful.

Rule of thumb, try find a solution or workaround somewhere. If something weird happens, it’s most likely a bug, not something wrong on your side.

Same issue after UK update. Disabling photogrammetry fixes it, but really don’t want to lose that. Trying to enable photogrammetry mid-flight will get stuck on please wait page, or doesn’t bring photogrammetry at all. Could be a network issue but my network environment didn’t change at all.

Edit:After looking through the forums I found out the issue is caused by not setting non-unicode system locale to English. Never thought language setting would affect network connection.

3 Likes

Thank you for your input, I have added your solution to the top :smiley: much appreicated.

Thanks for the updated solution!

1 Like

Same problem here with my CHS-unicoded system and turning BING-OFF worked.
It’s not a solution, it’s (one of the) defects that ASOBO should be responsible solving! We all paid to get full functions of this FS, regardless of the language or unicode we use!!
Don’t know if ASOBO can work this out!!!

Same issue, looooooooooooooooooooooooooooooooooong time…

Turn off the Bing map works for me, thanks!

At least this is a temporary solution for me. I have logged a ticket to support and waiting reply.

1 Like