Stutter issue when flying low and close to mountains

Hi all,

I notice some severe stuttering when flying close to mountain walls.
Not sure yet what exactly is causing it nor do I know if this is a known issue.
So therefor I would like to know if you out there are experiencing this as well.

For example try flying through small valleys in the alps close to mountain walls.

My specs:
5900 X
6800 XT
32 GB G.Skill @ 3600
MSFS is installed on a 970evo plus ssd
300mbit connection

1 Like

Stuttering is random and everywhere.
SU7 Has destroyed what smoothness we had before


Set “Off Screen Terrain Pre-Caching” to ULTRA can reduce stuttering.
Resetting or deleting Rolling Cache can help also.

Here are more setting tips:

@SAKISAPPOLON I have no stuttering, please speak for your self. It is not “we” in most times it is error 60 (60 cm in front of the display).


guess what? You,are also not WE
WE have stutters with pg on,while before we didn’t.End of story,That’s why these topics get created

You are also not we because if we’re not mainthread limited most of us don’t stutter at all.

Only YOU are in control of your settings.


No matter if I am We or Us are Them:

Despite my high end rig, FS stutters quite a bit lately!

in VR, I (we) even get total black-outs since SU7, lasting 1 -3 seconds. Very unpleasant, in particular if that happens while doing the Mach Loop or on short final…


Hi @Grabber523 according to your manual You provided changing the render scale to stress the gpu more didn’t work for me. I scaled to 150 and I was getting around 25ms latency on the gpu. This caused my fps dropped to 40 with stutters, especially when panning.

The picture below shows the settings I fly with from the beginning. Giving me smooth 60 most of the time.

The stutters I encounter seems like they are bound to a specific area.
I can tell this as I’m flying a specific route through the alps and at that one same spot every time, stutters occur.
Could it be some odd terrain/mesh data??

The rest of the flight went smooth apart from a little hickup every now and then.


If you are curious, you can fly this exact same route as I will provide you with the details.

Sorry but I wasn’t able to upload the .pln file as this forum won’t let me.

LFLB 45,668/5,88 45,671/5,904 45,551/5,868 45,457/5,803 45,346/5,605 GRENOBLE 44,898/5,683 NOTREDAME 44,806/5,948 44,706/6,036 44,646/6,163 44,686/6,262 44,752/6,253 44,761/6,358 44,778/6,4 44,787/6,557 LFNC

Approx 10 minutes prior to landing you will come across this part of the route.

This is where the stutter happens!!

Edit: you can fill in the coordinates in the world map, if I remember correctly. Haven’t done that in a while.

For most folk the stutters happen at busy airports and over photogrammetry. Even then you clearly have the right idea by not pushing the LODs so high that you get mainthread locked. That problem scenery could be a glitch.

1 Like

exactly,cause i also am on a 6800xt Nitro Plus S.E pc etc etc 8 core cpu etc etc

Try dropping your Terrain LOD to 100 and see how it responds. I dropped mine to 50 (Nvidia 2070 Super) and no stutters now. Looks like junk, but no stutters. Setting to 100 seems to be a good compromise.

Lol … Guess it’s time to zip that G-suit a little bit tighter (no seriously - it’s in the assistance menu) :grinning:

1 Like

I know (and of course, I proudly wear it while flying the Hawk!)

1 Like

The render latency of your GPU is still too low according to that photo you posted. Also, just forget about your FPS in flight. It doesn’t matter, and at the risk of sounding too harsh, I don’t care. Lock your in-game vsync to 30, and set your latencies according to my procedure, then test it again.

Me flying the same route as you, with my rig and my settings, won’t help you.

It will help as I suspect shady terrain data. So if you and others can confirm this issue is related to the terrain data, it will be one step in the right direction to pass through a solid report to zendesk.

And yes, I did lock my vsync fps setting to 30.
It causes stutters when panning the camera back and forth, so I rather keep it the way it is now.

Against my better judgement, I flew the route using the waypoints you listed, and hand-flew the entire route, mostly through the valleys below 1000’ AGL, with a couple of climbs over the peaks to ensure the widest range of scenery loads possible.


Over the course of the entire flight, I observed 2 barely-noticeable, single-frame hitches due to mainthread load. There was a remarkable lack of any stuttering or hitching beyond those two incidents, and I can easily chalk those up to scenery loading, since I have never flown in the area prior to this test flight. If my Dev Mode FPS counter was off, I would not have seen the latency bar hits on those 2 occasions, and would not have noticed them otherwise.

Aside from that there was some light terrain morphing at higher altitudes as mountain peaks got closer, and a few tree tops floating a maybe a hundred feet off the ground, which is the first time I have encountered that.

This is my screenshot on approach to the airport you listed as the last waypoint in the flight. Notice that the mainthread latency shows approximately 15 ms and the GPU latency shows approximately 23 ms.

This is the screenshot I took after landing. The screenshot did not catch the observed latencies well, but they were approximately 17 ms for mainthread and 21 ms for GPU.

I cannot substantiate your claims of bad scenery. Everything was smooth, and panning was a non-issue.

Now that I have given you the courtesy of taking the time to hear you out, fly the route myself, and document my observations, perhaps you can do me the courtesy of actually reading the thread I posted, word for word, making the adjustments I describe in that thread, and do your best to understand that your stuttering problems are coming from your settings.

I covered everything in that thread very thoroughly, especially in the details I added in my responses to users and the questions they presented to me.

And in case you need to know my specs and settings:

10700K @5.1 all-core
32GB 3600 CL16 RAM
3060ti GPU, Mild OC
LODs at 175
All other Graphics settings maxed out
Render Scaling at 65% of 4K (using Nvidia Dynamic Super Resolution) on a 1080p monitor
In-game vsync on at 30

1 Like


Thank you very much taking the time to check out this route.
I will study your thread and will report back my findings.

Expect my results and feedback further down this week.

Cheers Mark

You bet! Good luck.

1 Like

Stutters when flying close to mountains is very much a thing in the game; I’ve experienced it many times. Luckily my technical knowledge about game performance is high due to being a game dev so I have some insight to share.

The first time it happened I thought the game was bugging but later I realized that the most likely culprit is that my GPU is getting over stressed because suddenly the physics engine is being pushed really hard by the proximity to the mountains.

As the aircraft gets closer to the ground, the game has to create a collision mesh for the ground and do constant collision checks between it and the aircraft. This can be very expensive from a performance perspective due to the complexity of the two collision objects. You’ll simply need to trust me that physics calculations between complex shaped geometry is way more expensive than you may think on the GPU and gets exponentially more expensive as the complexity increases. This kind of calculation can bring a GPU to it’s knees if it’s not optimized. (I have a VERY strong hunch that Asobo needs to do some optimization work here as it will also help performance when landing at large airports)

Those players who have already maxed out their GPU with other graphics settings may find that it simply can’t handle the extra burden of the complex collision calculations at the same time and will see sharp fps drops when near the ground, and especially near complex ground like mountains.

So how do we solve this? We need to lower our graphics settings. Give our GPU the extra room to breathe so it isn’t overloaded in rare situations like this. We could either lower our settings permanently, which sucks, or just drop the Render Scale option whenever we run into these situations. It’s a quick tweak that can be done on the fly that has a massive performance boost. Then swap it back to normal when we are clear of the mountains.

Give it a try to see if it’s the cause of your stutters. Fly near the mountains again but drop your render scale massively just for testing purposes. See if it fixes the stuttering. If it does then you know that you’ll need to tweak your graphics settings in future when flying near mountains.

You may also find that simply lowering the Terrain Vector Data setting is enough to solve the problem. This controls the complexity of the world mesh, and if they use that mesh for the collisions then lowering this setting would make a huge difference to performance. I haven’t tested this though.

1 Like

While your response is thorough, your thinking is backwards. The CPU appears to carry the burden of calculating mesh, terrain, objects, etc. That’s why people are going mainthread limited, and therefore experiencing stuttering, while close to the ground. That’s why you have to overload the GPU with max settings and control the amount of load it experiences using render scaling, then measure the render latency to ensure you are in the sweet spot. You can easily observe this behavior for yourself in the dev mode counter. My method is based on testing, not speculation. Reducing LOD is the fix. It really is just that simple.