Stutter Stutter and more stutter

What about network?
LAN or WLAN?
Are other computers streaming at the same time?

the main problem is often the cpu, which kind of i7 is it ? And I assume 1080p ?

Under normal conditions you should be able to fly without stutters ( I know, there are exceptions ). You can may be made some screenshots from taskmanager to give us better idea whats happen ( the page with the details, and also cpu-per-core diagramm ).

Also mention the airplane you use. As example a a320 is much more cpu intensive as a c172. If you have other tools running in parallel, it would be also intressting.

1 Like

No. I’ve tried this both ways as well. Not only that, I pay extra package with my internet server to get the fastest speed.

Everything else runs smooth BUT MSFS. It HAS to be a bad bug.

I’m not sure how to look up specs in that detail. But I’m saying why is it behaving like this at the LOWEST settings. I’m talking everything set to low. Even screen resolutions are in the 3 digits. I brought the setting so low that everything was pixilated and still stutters.

I was trying out the new 737-700 over the last week or so.

But it does this with most planes

1 Like

well, open Taskmanager and make a screenshot similar to example ( ALT + print ) … best if you let MSFS runs in parallel.
( “snap” tool is also helpfull ) . The “per core diagram” you get with right click onto the “normal” single-cpu diagramm and choose “show logical processors”.

The 737 is of course cpu intensive. For finding issues we should start at the smaller planes like the C172, and also regions on which you not have add-ons.

Intressting would be if you get also stutters in low-dense areas ( e.g some in desert ).

example Taskmanager shot:

Read through this thread, if you haven’t already.

It’s because it’s your cpu. I have 8700k and it’s bogging down hard . When I fly at 10,000 ft or higher it’s smooth. When I’m on ground taxing, depart under 10,000, approach under 10,000, landing ….it’s horrible. I just placed order for z690 & 12700k. I’m dumping my z390/8700k. I already got a 3080 . My bottleneck is the cpu/board .

1 Like

I own same cpu :wink: … you have to aware about the LOD settings. Not go higher that 200 in dense areas, better 150.

EDIT: I also forgot to mention. I run my 8700k in OC mode “sync all cores”, so I boost all my cores to 4.7GHZ . It needs a slighty voltage adjust and good airflow.

2 Likes

I’d never looked at the task manager in this much detail before in-sim, but here’s mine with maxed settings flying the 737 over southern France. No stuttering in a few days. Quite smooth. Aside from using the ‘skinny’ NVIDIA driver, I’m not really doing anything special. It would be great if they could normalize performance. 'Hope you get it sorted!

1 Like

well, your system is compared to the OPs system, much more powerfull :slight_smile:

We had in parallel a chat with the OP and trying some things. e.g. it was Geforce Auto-Optimization enabled etc.

The gtx1660 can also limit some things, as we see within the screenshot. So the game setting needs a bit fine-tuned. I also hope we find a setting for him that works well…

The system " stock 8700k /16gig RAM / gtx1660 " should be able to run the game in 1080p / tLOD 100 / Medium setting (as starting point) well. If that not works, we need more ideas about possible reasons :slight_smile:

Are we talking terrain or objects, cause objects could be really tough on any system if pushed.

Are the mems ok? Optimized…XMP or DOCP in Bios? So you run at right settings?

Try putting your Render scale higher, to always be GPU limited. Try with 125 and start testing from there to 140 or so. This really helps getting a smooth sim. Try to get around 20-30ms on the GPU graph in developer mode.

1 Like

@jfim88 what you say is what I currently know about the sim as well, but today I was watching Flying Fabio test out the new Fenix. His hardware is similar to many of our high-end systems here on the forums.

What I noticed was that his main thread was being hit hard! Like 30+ms at times, yellow and reds bouncing all over, his GPU latency was maybe 15-20ms, and he was perfectly smooth. I would have expected many more stutters watching his main thread get hit so hard but it didn’t. Smooth as butter. I’m trying to figure out why! And his settings are posted on his website so its really no secret. Maybe his internet connection is super-stable or something…

1 Like

Open the task manager - click on the Processes tab - click on the CPU column. Observe which programs are causing the highest CPU load. Malwarebytes was hogging a lot of CPU time on my pc. When I disabled Malwarebytes my random stutters went away.

1 Like

Ah… I am a Malwarebytes user! Thanks for the tip, will report back on that.

Define ‘pretty high end machine’ for us.

I’ll drop that here as I see Windows 11 style explorers…

Latest gen intel (12) or ryzen, and a 30 series card. At least 32GB RAM. I would say a lot of folks have recently upgraded to just about these specs. Maybe some still running 10th or 11th gen and a newer card. Anyway, that’s, my loose definition for Monday!