Stuttering makes flight simulator unplayable after last update any ideas?

I tried that and it doesn’t help. I tried lowering the graphics and still no change. Tried shutting off data and that doesn’t help. I guess I’ll have to wait for an update to fix it. I tried everything I could think of.

Very likely, the reason is that you’re limited by Main Thread, and you need to make sure that your GPU cannot outrun your CPU, so to speak.

In addition to the AI suggestions above, your best chance of relieving the CPU load is to reduce Terrain LOD.

However, this may not be enough without sacrificing a lot in terms of drawing distance, in which case you can try to set a hard limit to the frame rate, either with Vertical Sync or some external means. I use the nVidia Control Panel for this. Yet another possibility is to increase Render Scaling to keep the GPU busy. Of course, the limit must be lower than what you typically get now.

Use the internal FPS counter in Developer Mode to see the effect of your efforts. You must aim for GPU latency to be slightly higher than Main Thread Latency.

Note that “lowering the graphics” is actually counter-productive here because it allows the GPU to render even faster.

Edit: Of course, it’s entirely possible that something in SU9 + hotfix makes it impossible fix the issue satisfactorily. The above is a general method to reduce or eliminate stuttering caused by unbalanced CPU/GPU latency.

1 Like

There was just another update but it didn’t fix anything. I tried low, medium, high, and ultra and turned everything on and off. Its still bad FPS on the ground and just a little better in the air but as you approach any airport the FPS is way too low to even land. It’s still unplayable. I tried reinstalling and tried different nvidia graphic drivers. Tried nvidia settings on and off. There’s nothing that can be done until it’s fixed. Before, I had no problem at all and I have a 3080 graphics card and a very fast PC.

When I had microstutters and tried everything I could think of, the only thing that fixed it was a fresh install of my system, reset also the Nvidia control panel and reset all the settings to how they were. Stutters are gone.

delete the CONTENT.XML file in the MSFS folder it will rebuild itself on startup. You may have old addons that have remained inked in this file and deactivate the rolling cache in case it is activated and check that you are in directx 11 and not directx12 in the game

2 Likes

Another idea is this (wow, I stress many threads with it today :smiley: )

at least on Windows 11 the latest update breaks the .Net framework (known issue) which may affect MSFS and/or other apps.

I saw the post for this and tried it but still nothing changed in MSFS. It’s obvious this is an Asobo problem that needs to be fixed. Everything was fine but after the latest updates it makes the flight simulator unplayable. Juswt have to be patient for them to get a fix.

I tried that and it didn’t help

I tried it and it didn’t work. Just have to wait for an update to fix it.

Not sure it’s the sim… it sounds more like your hardware or connection, as others would be screaming if this was impacting the majority.

Well actually I see a lot of people saying they’ve got the same problem since the last updates. Everything has checked out and I can’t find a thing wrong with the pc.

Strangely enough, i had a connection bug before (SU7 or after), that is when another laptop (Win10) uner the same Router is connected with LAN cable, it will make my MSFS freeze (for 1 sec) in every 4-5 seconds.

When I unplug my Laptop, the problem will be gone. Eventually, that Laptop connects with Wifi is all fine and i live with this until now.

Hope you can find the reason on your side, good luck.

There is nothing we can do about stuttering until Asobo fixes this. Will a stable DX12 fix the stutters? Probably depend on how its coded.

I think I finally have my stutters about as limited as possible. The last step was to turn off Malwarebytes while in the sim thanks to a very helpful post here on the forums. Also, double-check any other CPU intensive tasks that you might need to shut down.

My in game settings are mostly Ultra, 2k monitors rendered up to 130-170% or so, and my LODs are about 175 for terrain and 100 for object. This keeps me mostly GPU limited and helps smooth things out.

I am running just a bare Nvidia driver with no GeForce Experience on one rig, the other rig as GeForce still and I’m not certain that has been a huge game changer but it did cut down on CPU tasks.

I did the NDU tweak in the registry for mostly placebo effect. It felt smoother!

My Nvidia control panel is mostly “stock”, not really any changes.

I continue to experiment with V-sync, but on my G-sync monitor I personally seem to get better results with V-sync just left off.

I’m able to run in dense environments with the main effect being lower FPS and no real stuttering. I do get the odd stutter still, but it is a fraction of what it was when Malwarebytes was still running in the background. I think the last bit will need to be fixed by Asobo.

Hope this helps, or happy to walk through some tweaking with you.

Personally, I had an issue with even terrible performance on low settings, it was at that point I realized it a specific addon that was causing my issues, it was YouControls.

Had to delete it from both my community folder and the roaming file on windows.

Same here, but I limit the frame rate in the nVidia Control Panel. The cool thing with doing it this way with a G-Sync monitor is that I can tune the limit freely to match the CPU/GPU latency I can achieve.

1 Like

I agree we can’t do anything until they fix it. I tried everything I can think of and spent hours trying to get something to work.

It stutters bad on the ground and if you get close to an airport but it’s a little better in the air.

1 Like

@hendis55 so if your latencies are around the high 20’s ms, then what do you target the frame limit to be? Trying to understand this so I can play around with it.

That would be around 50 FPS (one frame takes 20ms, so you can produce 1000 / 20 per second), but I would set it a little lower to be on the safe side. And remember to tune for heavy load scenarios, i.e., on the ground at a big busy airport, in the most demanding of your favorite planes with lots of clouds, etc.

EDIT: Just noticed that you wrote high 20’s, so you may not be able to go as high as 50. But the formula remains 1000 / latency = FPS.