Stuttering performance in Vr mode?

Ya, a few things missing, but not too bad.

With SteamVR settings you have correctly selected global visuals = 100% and that’s correct. I would turn off the SteamVR home because it just wastes resources. Then go to the visuals setting and select the per app bar, then scroll down to the msfs app, then adjust the visuals to 350%. This will help improve your cockpit clarity when using dlss/balanced. You’ll probably still need to duck you head in to see some switches. Also, find advenced super sample filtering and disable it (tends to make some distant objects too blurry).

While your msfs PC setting don’t have a big effect on VR, I’ve found it best to set them to hi-end rather than ultra.

I’ve just published a fairly lengthy settings for what I’ve currently found work best with my Q3 and QPro using a Link cable. Except for the obvious Oculus/Meta settings (which I’ve tried to keep separate), I use exactly the same Nvidia, windows 11, and msfs settings with my Vive Pro1 and these work great. I suggest you have a look at these and give them a go. You can see these here;