SU7 VR comments?

Thanks for that, I was wondering where it went.

I’ve started a separate thread on that topic a couple of days ago:

Unfortunately, this is yet another installation of “released just a bit too early”. I forgot what I had read about getting it to do at least the basic stuff yesterday and deliberately tried it now w/o reading it again, to see how far I’d get.

I could get the left controller to work with the yoke (which is not what I’d want to use), the right controller didn’t work beyond the thumbstick mapped to rudder and while I tried to figure out myself what to do in the settings menus, the right controller turned itself off (low battery, haven’t used them in ages) and FS crashed. At that point I lost interest, knowing that some things (menus) won’t be working with the controllers anyway.

My point is, I can see how they had to push it out in whatever state it is on release day, because apparently someone somewhere in that company structure doesn’t seem to allow delays, or realistic time frames and deadlines. However, the point of releasing something new in an early development stage is to gather feedback and information. But that means that something needs to have a minimum usability beyond being a more or less dysfunctional tech-demo, if it’s not really usable people won’t be really using it and then they could’ve saved themselves the hassle of pushing it out and getting nothing but negative feedback on things they already know. This seems to be utterly pointless and I imagine it hurts the developers as much as the users. Please stop doing that.

2 Likes

EbiDevil

7h

try settings, camera, standard cockpit mode = on. this fixed the toolbar for me.

This does not work fully as I seem to have to keep explaining over and over.

If you use Cockpit zoom in VR (who doesn’t?) to look closely at instruments, you will notice that this no longer works in “standard cockpit mode = on” nor does it work in the CTRL-0 workaround.

If people insist on assuring us that they have fixed the toolbar issue (and many have) please test rigorously before proclaiming to have solved it.

1 Like

Control-0 has fixed it for me as I now have full access once again to the tool bar which was the problem. It is not mine or anyone else’s job to “test rigorously” before announcing it, we pass on the info and you yourself can test it to your heart’s content. If another issue isn’t fixed with that solution or you’re not happy it is not the fault of the person passing on the info, something everyone else seems pleased they have done. And not everyone uses VR zoom, I never have done. I prefer the more robust, organic zoom method, I lean forward.

2 Likes

Question: Is it fixed or is it broken?

Answer: It is broken.

If you are happy with it the way it is, great. A lot of people rely on Cockpit zoom function and it cannot be used if you use the above workarounds. We need Asobo to issue a hotfix. Proclaiming that everything is fine and dandy does not help us get back the functionality that we had pre SU7.

You say “we pass on the info” I think you’ll find this info was first discussed yesterday by myself and others with the proviso that It is a WORKAROUND not a FIX. You are not passing on anything that hasn’t already been discussed at length.

https://forums.flightsimulator.com/t/toolbar-broken-in-vr

https://forums.flightsimulator.com/t/cant-access-vr-menu-after-update

1 Like

No one has ever said it is fixed, this is a temporary solution. And not everyone has read that specific thread. We as a community should try help each other. I have posted this temporary solution on other threads and have had people thank me for it. I myself discovered the solution on an influences YouTube channel comments. I then commented on another’s and he has since done a video showing it. This is how we help each other, we spread ideas and solutions for people to try.

If you’re not happy with the solution fine. If you’re still angry with Asobo then fine. But don’t go around telling others not to post very helpful information. Information that might just get poeple back enjoying the game again like it did with me.

If you disagree with these posts I suggest you just ignore them and move on.

2 Likes

Hello
since SU 7 it has been extremely jerky in VR. not playable.

no settings changed in vr.

it annoys after every update back to the beginning

No point getting grumpy with each other just because Asobo is making money doing a crummy job of quality control, yet quite possibly because some code ignorant pen pusher says it’s release date or else.

It is what it is.

So be kind and be thankful that people are doing their best to make this the best we can.

In other news, I aced pole position on my first ever Reno race and led all the way to win. I was probably up against a bunch of six year olds which, me being ancient, makes it even better. :grinning:

blows raspberry

5 Likes

I would add that releasing something new in an early development stage can only be done if we can fall back to the system that was previously used. I maintain that the mouse system in VR in MSFS is by far the most effective way to interact in a cockpit provided that you have a joystick.
But anyway, who could really pretend to control correctly a plane with a VR controller that’s free in space ?!

2 Likes

I apologise for getting grumpy at you. I agree with the sentiment of helping one another 100%. I just see a lot of posts that make the problems seem like they have been resolved. We should not settle for a workaround and must push the devs when they mess things up. Peace :v:

1 Like

Well, in X-Plane I learned to appreciate the right controller to operate the panel and found it in most cases superior (quicker and more natural) to a mouse pointer. I agree with handling the controls via the controller being quite pointless, although there are cases where it turned out to be a viable alternative (the short joystick of the Lancair Legacy for example, which has just the right position to fly the plane in a very relaxed way, with the left hand and the controller resting on my lap).

This is also something they should look at: In XP, both controllers are doing the same by default, I can use both controllers to either operate the knobs and switches and the yoke and if the right controller has a dead battery I can still use the left controller in my right hand to operate the panel or prop and mixture etc. The option to dedicate the controllers for specific roles is nice to have, but having to do that is not.

When well implemented, the 6 degrees of freedom in both hands can allow extremely precise inputs. For example in VTOL VR, it becomes possible to vertically land a jet on a helipad whilst simultaneously providing air support from the gimball cannon… However it is one of those things that you cant fully appreciate until you’ve tried it, a bit like the VR headset itself.

The current controls implementation in MSFS is nowhere near this unfortunately.

This camera setting solved the toolbar-problem for me too!

the camera setting makes the toolbar working for me too

but i am totally unable to understand how we can use the controlers to manages anything in the cockpit. For small buttons, quite impossible to target them, for the yoke, in the TBM for example, just by moving the small yoke on the left controler we can act on the flight but i don’t see the yoke moving…

I continue to use my T16000 yoke which is far easier for me.

Your work-around does not work for me. In my opinion this CTDs are caused by the new OpenXR Version 108 and we cannot go back to Version 107.

Have you checked and voted here?

What a mess. Unable to use toolbar in VR with mouse. Invisible C208 cockpit. TBM930 broken with no ignition switch, yoke can’t be hidden, engine sounds like a bag of nails.
All my settings messed up, so reset them… but then they reset themselves when restarting.
I’m far from impressed and now have a useless sim!

1 Like

Thanks buddy! Great hint

After updating SU7 the VR performance is very poor. In bush trip not able to interact with Nav and VFR map with mouse that sticks of the windshield at the beginning of the flight. Overall very poor experience after the upgrade and there is no option for downgrade it.