SU9 setting tweaks to reclaim SU8 performance?

Before SU9, I was getting consistent fluid performance with high/ultra settings (even clouds) and 30hz ASW with a Q2, 3080, and 5800x, OpenXR Toolkit set to 90, etc.

SU9 hits and I have stuttering and lower frames everywhere. The toolkit performance shows me locking frame rates for 18 and 30hz, and I’m at 80hz refresh rate for the headset, but things just don’t feel fluid anymore.

What can I try tweaking in SU9 to regain my smoothness?!

I tried following the tweaks in this 2020 fsers video

However even though I had a couple things set it recommended to change in Nvidia settings (I had max pre rendered frames set to 2, it suggested 1), if anything performance feels slightly worse.

I’m desperate. I was so happy with how consistent smooth I had it before and then gone in the blink of a Sim Update.

Tweaking is a waste of time. Wait for a patch or the next Sim Update.

2 Likes

Unless your goal is to make things worse :upside_down_face:

Sorry to hear you’re experiencing issues.

I’m running a Quest 2 with link cable on an i7-10700K, RTX 3070, 32GB RAM which is giving me gorgeous results in VR. Very crisp and fluid at 80Hz, render resolution 4864 x 2448, OpenXR Toolkit at 100%, FFR off, and in-game resolution at 100%.

I’m running Oculus version 40 on my PC (I’m subscribed to the public channel). My headset is still on ver39 as it hasn’t updated yet.

My max frame rate is capped at 40 FPS in Nvidia which I can maintain for many of my flights. For that reason I typically disable ASW because I don’t need it, however, I can enable 30Hz mode if I wish.

I know it may sound strange, but have you tried running a test flight with an empty community folder and the OpenXR Toolkit temporarily disabled to see whether that makes any difference?

Happy to share my other settings if you think they would help?

Cheers

I am now six days in to using the Quest 2. I have a single word for my experience so far: Disappointing

Really want to like it, but when you can’t read the panel and the landscape looks blown out and monochromatic? No thanks. Performance is not the issue; the image quality is terrible.

Pattern work is the only thing I can see myself using the headset for at the moment.

By comparison, 1080p flat panel performance is beautiful and stutter free even at typical trouble spots like KSFO in a complex model like the DC-6.

Mainboard: Gigabyte Aorus X570 Elite Wi-Fi
CPU: Ryzen5 5600X
GPU: Gigabyte Aorus 5700XT

  • AMD Radeon Driver Version: 21.11.3 - Driver only installation

Memory: Corsair Vengeance 3200 - 2 x 16GB
Storage: WD Black 1TB NVMe SSD
PSU: Corsair RM850x
Noctua CPU cooler - NH-U12S-SE AM4

Make sure you try the Open XR Toolkit - I use it with Quest2. I prefer not to use SteamVR and use ASW / Motion Reprojection at maybe 27.5 (one-third of 80Hz)

I’ve had worse stutters since SU8. Good FPS though, just bad frame timing it seems.

What are you doing in terms of live weather and traffic? I usually have both on.

I use OXRTK with FFR and usually render resolution at 85-90. If my headset is at 80hz, I don’t have a 27.5 ASW option. it is 15 30 or 45. So I’m wondering if 72hz is the way to go because I can’t always consistently hit 30 for 1/3 of 90hz?

With respect to Steam users, one thing I learned while troubleshooting was that my performance is outstanding if I launch MSFS 2020 first before launching SteamVR. Once it loads up, I then run SteamVR and flip into VR mode. If I do that, I get 40 fps with my 3080 and everything is great. If I launch SteamVR prior, regardless of whether I then launch MSFS2020 in my Steam home or on the desktop, I get god awful stuttering even of the splash screens. I have no clue why but I’d love to know if someone has the answer. I suspect its not just an FPS GPU-strain issue but rather some other cause of stuttering because if I drop all of my settings in that context, it acts exactly the same (which makes sense given that the splash screens will stutter in VR). Again, if I fire up SteamVR for my Valve index AFTER launching MSFS, everything works great. It took me a lot of troubleshooting to learn that this basic order of operations was significantly impacting performance.

2 Likes

OMG! You found the secret. Thanks so much for this. This seriously works.

To explain, I have the Steam version of the sim but I have a Reverb G2 and therefore can run the game via WMR’s OpenXR or Steam’s OpenXR. I’ve never been able to get Steam’s to work without stutters. It didn’t matter really because I got great performance via WMR. The biggest headache for me with WMR though is I can’t use motion reprojection because of bad artifacts. Again, I have it running well but for sure it would be even better with motion reprojection.

But with your tip Steam works now stutter-free and in addition I can use motion reprojection via Steam. This gives me even better visuals so I’m excited to be able to use Steam over WMR. This is a significant improvement for me.

Note that I tried everything to disprove your suggestion but I couldn’t. Ultimately it works just as you describe. If I start the game with SteamVR running then I get stutters no matter what I do. If I start the game first and then SteamVR, there’s no stutters and my performance is great.

Thanks so much for this tip! :+1:

3 Likes

Try this!!

Works like a charm!!

So I don’t use Steam to launch. It is the Steam version, but launched from Oculus and OpenXR.