Suddenly missing a .dll file. Sim won't start

FS2020 worked fine this morning, and yesterday, and the day/week before that. But this afternoon, see below. Too much to lose by reinstalling and it may not work. Help please

A search for the error code brings up this link: Something Went Wrong

This is only one of many suggestions from Google.

I was having the same problem and had this suggestion given to me and now no problems.

I’m not much into this kind of problem but it worked for me. Different .dll had two both problems are gone now.

Thanks for the thought. Had a look at the info on it but it’s way outside my skills. I just want fly

I was in the same situation! You don’t have to do anything Just download and just install it and it takes care of everything else. You don’t have to know anything or do anything it take care of itself. I know less than you and don’t want to do anything but fly also. The problem was gone. Below is all I did.
this was the E-MAIL I received from the Logitech tech." Ticket Number : 9433474

Sun, Aug 14, 2022 10:55 am

Logi Support ( Details


Alyzza P. (Logi)

Aug 14, 2022, 10:55 AM PDT

Hello Hank!

Sorry to hear that you are having issues with the panels as well. May we ask what particular flight sim software are you using the panels with? Please also try to download and install the latest .NET Framework for your computer to see if this resolves this issue. You can get it from this link: "

check that all updates in ms-store installed…

The common reported solution point to the gaming services, which possible needs to reinstalled ( if there was not an open update ).

Thats what you get if you follow the topic which @PacificSet90456 mentioned.

A more official description about how to update/reinstall gameservices is in FAQ:

1 Like

Happy to see the problem was solved. You might want to consider installing the app the Logitech gave me. From what I understand it just stops .dll problems by fixing them before you see them. It is a Windows problem not the sim. Again, just knowing enough to get myself in trouble, I don’t know how but it did work for my problems. Have fun flying!

Thanks to all, the problem has been resolved by following the suggestion on the error message, ie, reinstalling the sim. Just a few hours of downloading 140GB!!
However prior to doing that and while checking the status of windows updates I noticed one had stopped at 39%. That subsequently became ‘Download error’. I ignored it.
Doesnt seem to have made a skerrick of difference to anything but I am none the wiser as to what caused the missing .dll file or why the download problem has appeared.
Fortunately I can keep flying until something incomprehensible happens again. What fun.