Suffering with poor FPS after today's update? Please submit a ticket!

Mine is terrible since the update. How can they vastly reduce draw distance (yet again) & make performance worse.

Before the update i was almost constantly limited by my GPU (1080ti with a i7-10700k. Still waiting on my 3080 to ship) & now I’m almost constantly limited by the mainthread (CPU) with huge, long lasting stutters & CTD’s. Same settings as before, flying the same routes & without mods installed.

How can a game go so backwards 7 months after launching… oh yea, they’re currently trying to downgrade & bring it closer to the upcoming xbox version.


Can anyone advise if Game Mode should be ON or OFF please? I read many area where they state OFF and JazTwoCents (who is big on performance from Hardware), suggests setting it to ON.

LOL… so true.

I honestly believe the visuals in this game were probably the best at launch. They keep chipping away at making them worse, while somehow making performance worse as well. It’s baffling.


Ok, finally got another stutter fest of course at the end of a 10 hours bush trip of the Alps… this time flying at 1500 feet from Udine to Ronchi dei Legionari in live weather. I’ll try today if I can replicate it and thus if this adds to the problem locations or if it was totally random (or bush trip related?).
Interestingly, monitoring with MSI, no fps drop reported (!) cpu running normally, but gpu dropping to 0% use at each stutter. Temps normal. Both VR and 2d.

It’s far too complicated and time consuming to Submit a Ticket, especially if you do not have English as your mother tongue, but I want to take the opportunity to thank everyone who has done so, as I suffer from the same problem.

I spent some time flying around the Maidstone, UK area which is affected by the fps slowdown using the development mode to hopefully find the culprit. I have no idea what most of the stuff is, but at some point I changed something and the stutter went away. I turned off developer mode off and the stuttering returned. Unfortunately I didn’t get it to do it again but I did spot something on the attached pics which happened when the stuttering started and disappeared when the stutters did.
Hoping someone can shine some light on it

Edit: I’ve now cleared the stutter problem at Maidstone and have started a new flight with a different aircraft and it’s still good.
I flew through the problem area with the sim objects window open and ground vehicle check boxes checked, then returned to the area and the problem disappeared.
Now to restart the sim to see if it stays fixed

Edit: the fix works after a pc reboot. Just don’t switch off developer mode.
Does anybody have a good easily findable problem area I can test?

Today started up MSFS, on main menu I have 10-14 fps without even loading a flight. Loading up the flight results in the same unplayable framerate. Only a simulator restart (temporary) fixed the issue, until next time.
5800x, rtx 3080, 32gb ram, nvme 970evo plus drive


Headcorn airport in Kent (EGKH) is bad for me, and also tried 76T Bishop Airport, just NW of Dallas Tx, that is even worse…

Their communication skills have been lacking for quite some time in my opinion. Maybe it’s just me but they don’t really seem to be listening to the community. This is why I dropped X-Plane after many years of simming. Developers there seemed to be doing their own thing regardless of what a fair few of their customers really wanted. So, yes, I moved on.

I feel that a lot of people (no statistical proof, just based on a wealth of comments I have read) just want bugs to be fixed, aircraft systems and SDK to be improved so that we can get a better all round simulator experience. But the devs just seem to be going blindly forward in tunnel vision mode doing what is easiest for their skill set e.g. mainly scenery improvements. I am unfortunately now beginning to lose interest in FS2020 because the devs seem intent on only making this a good looking simulator which, to be honest, it was on launch, August 18.

A further point. I have dropped X-Plane for very good reasons (at least to me) but to be fair they got at least one thing right. A beta update system. In all fairness, betas there only usually became compulsory updates when most beta issues had been sorted. With MSFS 2020 the recent updates seem to be creating issues for quite a few people (me included) with no option to delay the update until issues are corrected. This is by no means a new issue and has been a forum topic for quite a while. I claim no credit here for being insightful. However, it is becoming increasingly clear (to me at least) that the update process is just not working. Yes, this has been said umpteen times before and yet a lot of us here are still having issues with dodgy updates. Are the Devs not listening? Apparently, not! Why not give us a beta test channel like there is in X-Plane or at least something else which doesn’t involve a forced update before problems are sorted? It must be obvious to a lot of us here that the current method of enforced updates by ASOBO is just not working.

So … Long story short:

  • please improve communication. Lately, this appears to have been severely lacking.

  • give us an alternative to forced updates. Your current method just isn’t working and is reflecting badly on yourselves and the sim

  • and slightly off topic for which I apologise, but please start to make this a more rounded simulator.


That was very apparent with the last Q&A. While I enjoyed the presentation format a lot better, the “we only allow pre-screened questions in pre-selected categories and a very narrow variety of topics we want to talk about” approach was not ideal. It just allowed Seb to pre-build some videos to state errors being reported were user error and not a problem with the sim, much like his reply to the report of the live weather bug in the previous Q&A.

So while the show as a whole is nicer, it’s value in terms of information seems to have dropped significantly. THat was a huge step backward in open communication IHMO.


I just found a boundary line running right across EGNX runway, almost north/south (more like NNW to SSE) cutting across the runway about 200m east of the Mike taxiway for those that know it.

I was able to map the transition line quite accurately using the drone camera to fly in and out of the “twilight zone” - dodgy frame rates to the west of the line (with high CPU load like others have reported), fine and smooth to the east of the line.

Just found it by accident but hopefully it might help those cleverer than me to do some testing. Or maybe it’s only there on my version of MSFS World.

Looks like my geofenced fps drop issue has been fixed. Just need to try a couple more locations to be sure

1 Like

The fps drop problem is now fixed… for me anyway. Can someone else try replicating my fix before I shout from the tree tops.

Let me check my infected area.

No, not fixed for me. The usual area for my test is unchanged. Stuttery like hell and cooking my processor.

1 Like

Yup. Same here. Randomly I’ll get 10-12 fps in the menu and super laggy. Otherwise, random spots all over the world where I’ll get severe FPS drops for a while. Sometimes short, sometimes long.

1 Like

Yes, I’ll try it

1 Like

The only downside I see, is now I have lots of vegetation on the runway and taxi ways.

Edit; fixed that “draw on terrain” note ticked

Yeah me too, I watched some videos on YT and some of them state that you should turn it on and some of them shouldn’t.
I don’t know why exactly we should turn it off, but this is what I found.
This post is 10 months old now and maybe windows did an update regarding to this problem already.

If you turn game mode off you should prioritize MSFS manually in task manager.

Hope this helps.

Ciao Mark :airplane:


I finally submitted a zendesk ticket for the first time as this issue absolutely needs to have as much visibility as possible…


So the fix for me was to fly in and out of an affected area with developer mode on, select sim objects, ground vehicles with their boxes ticked and the sim fixes itself. It may take a while.
It’s worked twice, but I don’t want to try it again because now the sim is running really slick