Suffering with poor FPS after today's update? Please submit a ticket!

Did you try it in the Maidstone area? Might be something different going on there. I just flew from the town to the wind turbine and back, parallel to the motorway

I just took a drone over Paris and the FPS tanked, quit to the main menu and the FPS was still awful so this clearly suggests (to me at least) that this issue is not just In Flight but a fundamental flaw within the program itself.

1 Like

HPET set off, 76T Bishop still at 2fps.

No magical solution, sorry for that

Which makes it a completely baffling mystery as to why it was not caught during QA!

1 Like

Maybe you need to desable it from the bios and from windows, sorry to says that it runs better for me than before the update

Sorry man, I know it feels like it did something. But it didn’t. Just google it for yourself if that link doesn’t do it for you

unticking Options > Terrain > Draw On Terrain fixes 76T

1 Like

If certain application need it, than I’ll take it on, that’s so easy… but for FS, and now, that’s run

Can you elaborate on this? Does developer mode have to be on all the time with the items listed always checked? Or is it just when a location is found with poor FPS?

“Disabling HPET distorts the system’s understanding of time, which causes the system to miscount the frames in a second. If one second isn’t one second, then FPS isn’t FPS anymore. This data is invalid.”

Direct Quote from the Director of Technical Marketing for AMD. Its the same with intel

I’m now flying, you can say everything but in reality, that’s very better for me, incredible to need to explain that with other peoples, that’s fix the problems for me, that’s all… for you, I don’t know I just wanted to help if it can be better for others

The game hasn’t be as fluid as now

Perfect. If its better for you who can argue that. I just want to make sure everyone else on here doesn’t start screwing with their system for no reason

1 Like

Switching off developer mode kills the fix. But it still works after pc reboot

After many tries, it doesn’t work as good as I feel at the beginning, but it looks better than… I want to use this until Asobo make a fix… Did that could cause damage for the pc ?

I decided to try a suggestion for Nvidia rollback to 457.30. I am using at GTX 1660 Super. The roll back did nothing. I got the same profile FPS hit that I was not getting before this forsaken latest update. This all but confirms that I am shelving MSFS until the next update.

No, you are fine. It’s just turning off things in your bios or windows config just because someone on the internet says it works can get you in to really hot water if you aren’t careful. What if that setting actually did matter and you had to reinstall windows completely because it no longer boots?

Just be careful what you do! Fly safe!

Tried that, and subsequently spent a while flying around Headcorn doing some testing. Initially deselecting ‘Draw On Terrain’ the framerate returned to normal, then selected ‘Draw On Terrain’ on and still the framerate remained okay. Came out of Dev mode, still the same. Went back to the main menu, then back to Headcorn, stutters were back, in to Dev mode again and deselected ‘Draw On Terrain’, framerate remained low with stutters. What ever I did I couldn’t get back to the stutter free flight. Shutdown MSFS, the reloaded it, back to Headcorn, stutters were there, back in to Dev mode and ‘Draw On Terrain’ to off, stutters were there, took off fly around over Headcorn and they eventually disappeared. Think you are on to something there, just wish I could get it to work on a consistent basis, thanks for the tip though, I’ll carry on testing.

Turn it off on the main menu before loading the flight.

1 Like

I will do, and now I will wait for an Asobo fix… that the only way I think but I think that it’s not for now, it will be long… afterwards, many thanks for your explications…

1 Like