T Flight Hotas X not giving full power

Has anyone an idea why my T Flight Hotas X is not giving full throttle in the sim? I have to assign a button to get full throttle, i have to push the button when my throttle is all the way forward then it is giving full power. I already tried to set it back to standart but that didn´t work out.

Show us your control mappings and sensitivity settings. Your problem can likely be solved from there.

The Z-Achse is my Throttle now its all the way back

And now it is all the way forward and it´s not giving full power

Have you gone into your windows settings and calibrated your joystick? (to make sure it registers full throttle movement).

Bind your Throttle action to Any Other Axis and see if throttle works to check if its software.

If Left Z is your throttle those two pics show Left Z axis does not go to minimum (the effect is reversed), and I’d say you might have a dirty potentiometer/resistor, or a cracked wire, a cracked board, bad cable, bad usb port, etc. If you can, put Alcohol in a little spray bottle and (if hardware is the case at all and you know how to do this) find the potentiometer and clean it with an ear cotton or such. Also check double binding. YMMV

I have it since 2 years and it started to bug a few days ago

I had to fix my TMWH Hotas that had a worn wire ribbon inside. Fortunately I know how to solder tiny wires.

I binded it to an other Axis and it was no difference it is bugging on other Axis too

Then you’re in luck. Chk for double binds, if its 1 plane, uninstall from inside MSFS and reinstall (re-download) and see what happens?
Revert back to "Default’ device settings and see what happens?

It´s on every plane and i already set it back do default but still bugging.

I wanted to make a bad joke then didn’t.

Bruh that´s not solving my problem xD

Do you have any mods in the Community folder?
If so empty that folder (or just rename it, MSFS will make a new one) and try.
This could be a conflict.

Do you have any mods in your Community folder?
If so empty that folder (or just rename it, MSFS will make a new one) and try.
This could be a conflict.

I have this exact issue - did you find a resolution? Thanks

Haven´t found a solution yet, i just binded a key for throotle power so i move the throttle forward and hold the button then it´s giving 100%.

I had the same problem with my tflight stick/throttle HOTAS X. Had to go to windows settings>devices and printers> right click on HOTAS X and select control panel. calibrated per directions and the throttle then worked in MSFS 2020. Gave me 100% at full throttle. Hope that helps.