TBM 900 Autopilot won't activate

I’m not sure this requires a formatted report yet, but I’ve been unable to get the autopilot to activate in the TBM 900. I’ve used the steps I’ve gone through in the past (set altitude, set heading, etc, then press “AP” when in the air) but nothing happens. The buttons on the panel to enable different modes seem to work since the light next to them will turn on and off, but I can’t remember if the AP button has a light associated with it so I can’t say whether or not that’s working. Was this changed and I’m doing something wrong now, or has anybody else noticed this problem?

What does the flight mode annunciator at the top of the PFD say when you select different fight modes or turn on AP?

Are you using the stock G3000 or do you have the Working Title version installed?

You forgot to turn on the auto pilot master switch on the overhead panel.

Part of the after start checklist along with fuel boost pump & Fuel auto switching.

The checklist is your friend