TDS GTNxi Very laggy

I’m experiencing very laggy interactions with the TDS GTNxi. It’s only happening while in VR.

So far I’ve tried:
-Reinstalling the TDS unit
-Adding exclusions for it to windows defender as suggested in another post
-Reducing detail level on the unit itself.

None of this has worked. Basically, at the start of a flight, it will work nice and smoothly. As my flight goes on…it becomes less and less responsive. Eventually there is a good 2-3 second pause in between my button press, and the intended result. It’s extremely frustrating to say the least.

Overall, my FPS is perfectly fine. It’s simply just an issue with the TDS unit.

I experienced this on DX12.

DX11 it was fine.

I’m on DX11 currently

Are you on TDS v1.0.2.4?

Yes I am.

It’s been happening for months now though, over a few different versions.


It is best to contact TDS Sim Software Support.

I have just install TDS GTNxi as well. It has killed my VR experience. Mayor FPS hit and I am on a rtx 4090 and i9-13900kf. Is it simply not for VR which would be sad?

I see this thread is a bit old but I also have a problem with the TDS GTNxi when in VR. I can load it and use it with no issue when in 2d mode but as soon as I put the Pimax Crystal headset on the TDS GTNxi 750 will not respond to any mouse inputs. Sometimes I can get it to load while in VR but no response to the mouse. If it does respond at all it can take several minutes and thus is unusable. I don’t recall this issue when using my Reverb G2. I too have reinstalled current TDS version, latest Nvidia driver for my rtx 4090 and emptied the community folder except for TDS GTNxi and the Just Flight Piper Arrow. Here’s another wrinkle, if I load it in 2d mode then put on the headset and select something in the TDS with the mouse nothing happens but when I go back to 2d mode the item I selected has activated. Anyone else experience this? Is there a fix?

If you go to their discord, you’ll find TDS very helpful and will troubleshoot the problem with you.

Thanks. I will that.

Turni off turbo mode on openXR toolkit if you have enabled

I am just now experiencing this exact same issue, and we are all stumped!! Works flawlessly on my older system.
(Only in VR)

Win11 Build 23H2?
Gamers have plenty of reports of performance issues on that build. Reverting to 22H2 seems to help.