Textron aviation Cessna 172 Skyhawk - Autopilot

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

Another issue, the autopilot is showing 400ft off the altimeter or vice versa. I have checked altimeter settings several times, always showing 400ft off of what I put in autopilot. No mods installed.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Have you tried pressing the “B” key to sync the in-sim Baro’s? just to be sure. You have to set the Baro pressure on the Autopilot itself (KAP140) by pressing the Baro key. But there is a known bug and just pressing B to keep them in sync is the work around.

Also are you using the default sim GNS530/430? If you are, you’re missing out. Grab the Pimarc mod!

1 Like

Hello skypilotYTS,

Do you mean “B” on the keyboard or BARO on the autopilot? I’m sure I am missing out, where do I get the Pimarc mod?

So in the 172 Steam,

You have the settings on your altimeter, but you also have it on your KAP (autopilot).

When you get your altimeter setting you need to set it on both, set it on altimeter like you normal do, then press Baro on your KAP you’ll see its in Hpg, hold the Baro button to change to Hg. Then set it.

Ultimately, just press the “b” key on your keyboard, this will sync both instruments to the required pressure. I recall when flying that plane and through help on here, there is a bug and basically hitting b is the work around to get everything meshed.

As for the Pimarc mod.

1 Like

Thank you!

1 Like

Moved to #self-service:aircraft-systems as this is not a bug report.