The White Dot (in the center of the screen) can Not be eliminate since the SimUpdate 11

For Xbox Controller and mouse users,when looking around from the cockpit perspective,the white dot in the center of the screen can not be eliminate by using the previous method.

This problem has existed for over a year. It plagues VR too when you use a mouse & controller. Too bad Asobo still hasn’t implemented a setting to disable it.

1 Like

I don’t think it takes many lines of code to realize the function of removing white spots. Why doesn’t the official team do it?

1 Like

Mine disappears after two or three seconds. You mean get rid of it altogether?

A clever user on these forums discovered how to get rid of the dot when using a controller. Not sure about mouse though.
This works on the Xbox version, haven’t tested on PC.

1.Click left stick to bring up the large round cursor,
2. then press any direction on the d-pad, this will hide the cursor,
3. Now click left stick again, white dot is now gone.

So thats: Click stick, press d-pad, click stick.


In VR Quest 2, Steam Version, Virtual Desktop, Xbox Controller, the white dot appears when switching or alternating between using the Quest controllers and using the Xbox controller (specifically after setting down the Quest controllers and engaging the Xbox controller). When it appears I just move the right stick upwards (there is no bind to anything) and the dot disappears after a few seconds.
This is very annoying as you need to occasionally use both controllers for different tasks on the ground and in the air.

Also annoying and may be related are the label popups that appear when you look at cockpit panel elements. How do you turn that off? I looked all over. Maybe if I could turn it off it will improve the situation. It also seems to get in the way of the Xbox controller functionality for some 3rd party planes like Vertigo, you need to look away from the lower part of the cockpit to the window in order to get control of the throttle (bind to the A B buttons).

I know this won’t help at all but I have never ever had this white dot since day one of release. So they need to establish why it is happening to some and not others. I am on PC, MS-store version.

If I don’t move perspective, it will indeed disappear after three seconds. But when I move my perspective, for example, I want to look out of the window, white spots will keep appearing.

1 Like

It should be players who use xbox controller or VR that have this kind of trouble.

And that’s broken now?

The method I described works on SU11, follow those instructions exactly and the white dot will be gone.

1 Like

That explains it, my misunderstanding. I do hope they solve it for everyone.

1 Like

excuse me,what’s the original setting for pressing the left joystick? I changed it to wheel brake before.

Clever Boy! It really works!
But it’s more cumbersome than before.
In the past, we only need to press the Dpad arrow key to eliminate white spots.

I just realised my personal solution to avoid this horrible white dot: I eliminated the X-Box Controller and moved the essential view functions to my throttle and joystick systems. It’s a bit of a change. But now everything seems much more real. Hallelujah!

Unfortunately, I only have a xbox controller.

I get this occasionally on PC too if I’ve used an option in the Dev Menu. I’m quite sure it happens when the sim 3d screen does not really seem to be the main focus for some reason.

Doing the method above will force the sim 3d screen to be the main focus, so the dot goes away.

I’ve had to do similar on the PC too, click on the sim screen somewhere to restore the window focus back to the sim 3d world.

It’s nothing to do with focus. It is meant to assist Xbox controller users to know where is the screen centre. It’s a cursor but always in centre, so why it is needed is a real puzzle. Even people that use it seem to miss the fact that it is just highlighting the screen centre.

The problem is that it appears for Xbox users AND even PC users who use the Xbox controller for camera movement. It appears when moving camera, even when viewing out of side windows when no cursor would be required. When changing views. After using mouse. etc. ect. Plus any of the so called workarounds don’t work, becuase the dot reappears as soon as any of the things mentioned above are done.

Anyway there is tons of info about it in various threads. We just want a way / option to turn it off.

TLDR: It is nothing to do with focus, or dev mode and if you have an issue there it is a different issue. :slight_smile:

All I’m saying is that I see it occasionally when I do not have the screen window focussed on PC. I do not have an XBox controller.