Throttle axis 50% - 100%, nothing in-between

Maybe this has been addressed elsewhere, but I haven’t been able to find an answer.

I can’t get my Honeycomb Bravo throttles to act correctly. They do in X Plane, but not MSFS. They are recognized and calibrated correctly. The sliders show full and incremental movement. Everything appears to be correct…except when I actually get in the plane, I don’t have incremental control over any of the throttles in single/twin/4 engine profiles. I only get 0, or 50%, or full 100% - nothing in between. The only way I can adjust speed up or down is to go to autopilot speed and dial in the numbers. But that only works in the jets.

Is this a sensitivity issue? I’ve tried various changes and settings in Sensitivity, but nothing works so far. I’m sure I can’t be the only one who has or has had this performance issue. I can adjust the incremental throttle levels by using the mouse on the monitor screen, but not the Bravo Throttle. Frustrating!

1 Like

What I love about this throttle is it’s accuracy. I think Honeycomb recommends to calibrate it for default and leave it alone. Here’s mine…hope this helps

I reset the settings and copied what you shared and works for you. Tried the new settings on the Baron and (so far) is working perfectly! Now I need to go back into the single engine 172/152 and 2 engine business jets/2 engine commercial jets/4 engine commercial jets. Hopefully, they’ll all perform as intended!

One major difference I noted is the joystick axis Y and X. I had the 0-100% option selected. And it was on R instead of L for some reason.

Also, in a possibly related way…I’ve found out that I have to independently clear an existing assignment, either before or after a new assignment, otherwise when I validate - both assignments will be binded to that button/axis. That may have been my issue!

1 Like


Moved to #self-service:peripherals where it’s better placed topic-wise.

Glad your flying again. I love the Alpha & Bravo they are accurate and add a sense of immersion they I’ve never had before.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.