Throttle wont go to max in f18

Trying to do training take off with afterburner but cant reach max throttle with x52 lever fully forward. Aircraft not going fast enough to take off properly and training keeps re-setting.

2 Likes

Getting the same problem T16000M. Get message push power to max , it is.

Use F3 on keyboard to start the afterburner

1 Like

Same for me using the Thrustmaster T Flight HOTA.

I have tried the F3 key no difference. I set the throttle to MIL then to MAX but still no afterburner, Just tried it in normal F18 (not Maverick one). Not sure why this is happening. I am using a Saitek X52 setup.

I have sorted this but a bit unusual I must say. Set throttle to MAX then hold down F3 for afterburners and all works ok.

1 Like

Assign a button to toggle the afterburner. Use it.

2 Likes

have to edit before. previously scriptum lol. all i said about physical problems i was sure you used binded button for afterburner. in osobo worlds you have to do this crazy stuff push forward to 100% and only that way “afterburner trigger” can works. if you don’t knew that. it just say nothing about your controller have any problem. but set afterburn to same double inverted axis(that way simulator will understand same physical axis as two digital axis) it’s really way to go for f/a-18 osobo

hi, you can create profile for f/a-18 if you use f-35 and f-104, or may be some other can works not correct if use it. any axis you use for throttle you have to use for afterburner. and this is best you can do for flight osobo jets today. that how that looks. throttle axis set you push from idle to max. afterburner axis set - you move the lever from max to idle and checking reverse is on. as result example “axis a” = throttle. “axis -a with set reverse” = afterburner. if you use multi throttle levers for engines a b c d so first engine throttle will set as axis a. first engine throttle will set as “axis a” first engine afterburner “axis -a” with turned reverse check mark and same for b c d. i have only two levers for throttles same used for afterburners and both works as together so separately. your afterburner will start not at 100% throttle but exactly there it must and will grows with push forward as it should be. and you can to check physical condition of physical axis. open your settings of controls and be sure it’s indicated as idle at 0 position and as full forward at 100 position. if you see indicator not go to max it can be because physical resistor moved by too aggressive moves. so you just can to do opposite - moves backward with some over force, that will back idle to 0 instead -3 and max to 100 instead 97. afaik resistors you use have some room out of 0 and 100 and can be recalibrate by reconnect controller. if not help, just pull buck forcedly. and in future try be more gentle with throttle for avoid this situation. most bad think can be is too old controller with lost good fixation of resister(s). in that situation for sure you need fix it or take new one
stay safe

Did and works fine.
Cheers!

Any idea how to activate war power, my efforts show "unavailable "

just set afterburner on same axis you use prop or mixture, afterburner axis at max will allow push f/a-18 normal, if move axis to min it will stop at max mil without afterburner and will works with 3rd party jets as has to. if you haven’t axis for that you can use button or same axis you use throttle. just opposite direction and revers mark or opposite. in this situation if you have 3rd party jets. you can create two profiles. 3rd party jets don’t need afterburner mapping. f/a-18 need

Can you please tell a ‘noob’ like me how to set ‘a’ button for afterburner? In the control panel, I don’t see an afterburner option.

Thx in advance.

type “after” in controls and you got some opinions for toggling it