Thrustmaster Airbus sidestick issue


Tried everything with drivers. Everything was normal when I was flying EGLL-EHAM and after landing in EHAM i tried taxiing and plane wont go right then did little research maybe it was Fenix and I find my joystick rudder won’t register moving to the right. I had vJoy installed a while back maybe he did some damage, now reinstalled it to see if it fixes the issue nope still the same, any ideas?

Known factory design defect for a few years now.

The wiring harness running from the base of the joystick to the top buttons/levers cluster regularly impinges the rudder potentiometer (which detects when you’re swiveling that axis). The only solution is to disassemble the handle and (gently, gently) pull the wire and give it slack around the pot. It’s a temporary fix, you’ll end up doing it again and again. My solution was to pass the stick along to someone who could use it and had other options for rudder control and get a VKB. Never looked back.

2 Likes

Yea I thought so but wasn’t sure enough, okey will do that thanks :smiley:

The solution…

:wink::vulcan_salute:t3:

1 Like

Thanks guys, it looked like I just had different diagnosis :smiley: but same issue as everyone else.

1 Like