Thrustmaster Airbus tca throttle quad won't go back to idle

After the latest update the TM throttle quad won’t go back to automatically go up to CL.if i move the throttle levers that has no effect,unless i grab them with the mouse then i can pull them back to idle…
any ideas i thought this was fixed.

sorted…for anyone else with this problem just set your sensitivities to 0% in the TCA quad setup section.only for throttles though.

Also worth a reminder that if using the FBW A32NX mod, you need to explicitly calibrate the throttles, in-cockpit, via the EFB! In this case, just use a straight, linear profile on the SIM control setup and let the add-on do the rest :+1:

after 6 update my throtle is all over the place thrustmaster is no longer callibrated worked just fine till update 6 mandated

set the throttle lever sensitivty to 0% both of the Plus + minus ones as well.once i had set the throttles to 0% both the throttle levers went back to Idle.

I have moved your post to Peripherals.

after latest update it’s worse than before…i’ve tried everything inc the efb detents page.nothing i do will make the throttle levers do what they are supposed to do.everything else ie spoilers flaps ign/start all work perfectly,just can’t calibrate the two Idle if i touch them they shoot down to reverse thrust.just a mess :-(.
hopefully next patch will fix it.

set to 0 and still can’t get throttle 2 to work, very frustrating.

My settings on the Thrustmaster Quadrant TCA 1&2

These are my settings for the Microsoft A320 Neo

Current settings for the FBW A320 Neo, set using Flypad.

Thanks man, I appreciate it

Me too did you fixed it ?

nope it didn’t work