Thrustmaster pedals center hard right


I am having issues with the thrustmaster TFRP pedals, the seem to have centered to the hard right. I have tried installing thrustmaster drivers, calibrating using the windows game controllers, and calibrating using thrustmaster advanced calibration and nothing seems to work. Any advice?


Can you show us the screenshot of your pedal control bindings? Have you check on the Sensitivity curve, between neutral, and when you move the pedals?

This should be under self-service peripherals and not under bugs and issues.

Quick foolish question: do you have the switch on the TFRP USB cable set to rudder instead of automotive? It’s possible to change the switch position if moving cables around.

Well that did it, thank you so much I had no idea that switch existed.

Thank you both for the fast replies.

Which I had such a switch on the Saitek Pro Rudder pedals - I have literally yesterday just had exactly the same problem - rudder output stuck on hard right, and no input response registered afterwards. Does this in all my flight sims. I’m resigned to think that the rudder pedals are broken!

Did you try windows game controller calibration?

Hi there Nick and thank you for your reply:

Tried everything including the game controller calibration.

Have resorted to purchasing the Thrustmater Rudder pedals - there not bad actually, not quite as easy to find the centre when flying, but otherwise not a bad piece of kit. Can’t get the Saitek/Logitech ones anywhere, unless you go to various unscrupulous sites that sell them for twice the price!

Having a similar problem (biased to the right of centre, not full right). The Windows Game Controller settings doesn’t give me an option to calibrate the pedals. It does for my HOTAS and Thrust Levers though.

If you look down on your cable thaylt connects your pedals to the pc or throttle there should be a big block. Make sure the switch on the side of the block is set to airplane and not car.

When the message pop up to activate, close, it’s a bug, and start loupedeck again, after it should active