Thrustmaster TCA Addon issues

So I just received my TCA airbus addon and throttle quadrant and after a few hours of searching the forums I was able to fix the issues I was having with the throttle not lining up. but i cant find anything the speed brake and flaps not working properly. My issue is that when I lower the flap it goes all the way to full flaps when it should be on flaps one and the same with the speed brake it goes full on the first detent. I’ve tried calibrating multiple times and nothing so if you guys could help thank you.

When you calibrate your TCA Quadrant with the addon. You have to move the spoilers and the flaps with the throttle as well. So these are the steps.

  1. Throttle to TOGA, Spoilers Up, Flaps Up => Press two red buttons.
  2. Throttle to MCT, Spoilers 1, Flaps 1 => Press two red buttons.
  3. Throttle to CLB, Spoilers 2, Flaps 2 => Press two red buttons.
  4. Throttle to IDLE, Spoilers 3, Flaps 3 => Press two red buttons.
  5. Throttle to full REVERSE, Spoilers Full, Flaps Full => Press two red buttons.

Then you can press the two black buttons in the front to complete the calibration process.

The reason why you have issues with the spoilers and flaps before is because you didn’t move them during the calibration. So the hardware is recording that your up positions are the calibrated positions, so when you move them, they jump directly to full. That’s why you need to calibrate them with the throttle together. So the hardware can read the positions of the spoilers and the flaps as you move the axis to calibrate them. This is the step that Thrustmaster failed to include in their calibration process.

You might notice I give you an extra step with the Reverse. This is important because the steps provided by Thrustmaster officially is missing that step as well, which gives you an issue with inconsistencies between the two throttles and the throttle jumping around when enganging the reverse. So it’s important to press the two red buttons at every detents.

(It’s also the 5th time I provided these steps to this exact same question and I don’t even have my Addon yet).

I’ve seen your post in other threads and I’ve tried those steps as well and it doesn’t work.

Really? I got confirmation from other people having the same issue and they said it works.

yea man I’ve tried it just liked you’ve said multiple times and it doesn’t for me.

Hmm… I dunno… seems weird to me…

Try post the problem to this topic while linking back to this topic as well. Someone who are already active in that discussion could pitch in to see if there’s something both of us are missing:

decided to try it again seems like its working this time thanks man.

Ok i just recently received my thrustmaster throttle, how did you manage to align the throttle to the cockpit, I ve tried a lot of different suggestions

This is what i used to get them aligned. you need to find the file they are talking about

I got my addon today and, oh wonder, it all works SUUUper!
Except the Autobreaks doesn’t fit that great.
But now I’m waiting for the A350 - then everything will be fine.

Gruß, with a grin over all cheeks :sunglasses:

Now only the autopilot has to work and we have a “flight simulator”