Thrustmaster TCA quadrant still not completely working

With update 5, settings were added to support the Thrustmaster TCA Quadrant Airbus Edition. It is greatly improved versus the manual mappings before, but there are still some notable issues with it.

  1. Buttons 7 and 8 are not mapped at all by default. This is the Engine mode selector knob. I can manually map button 7 to crank mode and button 8 to Ignition/start mode easily enough, but when turning the knob back to the normal position (deactivating button 7 or 8), the in-sim knob (a320) does not return to the normal position. You have to manually switch it back to the normal position in the sim.
  2. the add-ons (hardware) have not been released yet but appear to be mapped in the default profile for the quadrant… that sounds fine, except that the currently non existent flap lever is causing the flaps to go on full even though it doesn’t physically exist. Any time I hit escape to the menu and then resume, my flaps immediately go to the full position. I had to unmap the flaps setting completely to get it to stop changing my flaps setting.
  3. The Fuel valves for engines 1-4 are all mapped to button 3. At the least, fuel valve 2 should be mapped to button 4 (the engine 2 switch). With the default settings, if you switch off engine 1 (button 3) the switch for engine 2 in-sim starts having a seizure. I had to remap the fuel valve for engine 2 to button 4 (engine switch 2). The default setting is an issue not only because it creates a conflict with button 4’s assignments, but also since the proper startup procedure for an A320 is to start engine 2 first which would need it’s fuel valve open.

Lastly, as a note, I did have to very slightly adjust the sensitivity curve so that when my throttle levers are in idle, that the sim actually registers them as being in idle. The default curve caused the sim to think my left lever was at +4% and the right lever was at +1%. This could just be an issue with my hardware, but I imagine there will be others with similar hardware variations in the throttle position sensors too.

17 Likes

Just tried my quadrant and had the same issues with the button 7 and 8. As the norm position has no button we cannot bind it!
Will test the sensitivity thing to check if I am on Iddle.

Can you please share screen captures with the final config removing the ■■■■ for the addons?
Thank you!

Hello, same issues here. Can not get the engines started. I’ve remapped the fuel valve, but no engine start with buttons 3 and 4.

And how about the reversers, how to map it?

The reversers are fine by default.

1 Like

Hey,

Thrustmaster released a document - at least for the last MSFS version.

More than this, will currently not be possible propably.
give it a bit more time.

http://ts.thrustmaster.com/download/accessories/Manuals/TCA_Quadrant/Microsoft_Flight_Simulator_Thrustmaster_Abnormal_Procedure_-_TCA_Quadrant_and_TCA_Officer_Pack_Airbus_Edition_-_22_10_2020.pdf

1 Like

The reversers are working correctly with the default mapping in today’s update. At least, they are for me. I noticed that not only do the reversers activate correctly, but we also have (limited) control of the reverse thrust/engine speed depending on how far into the reverser area the throttle levers are pushed (pulled?).

The update 5 today makes that document outdated.

I have the problem that both lever aren’t together aligned ingame and FLEX and CLIMB isn‘t at the correct position. Reverser are fine.

When setting both lever to idle, only one is idle. The other one is at around 39%

That was the temporary procedure to do before todays MSFS0202 update. Today’s update adds default support for the quadrant so that procedure is no longer needed. However, today’s added support isn’t quite perfect, which is why I posted the issues in this thread. Most of the issues can be fixed with some manual button remapping/unmapping changes. The only one that can’t be fixed manually is the engine mode position knob not following in sim when set back to the normal position.

Are you able to start the engines with buttons 4 and 3 on the TCA Quadrant?

I had the same as noted near the bottom of my original post. You might need to play with the sensitivity curve a little bit inside FS2020 to get it to match up (assuming you have installed Update 5 in FS2020 and loaded the default profile for the quadrant under controller options)

nope.
And for some reason the only thing I get from flipping the switches is turning on and off the X-feed.

I‘m only able to shut down/ start engine number 1. Engine number 2 isn’t responsible and does everything engine 1 does too

Can you please share a screenshot from your sensitivity settings?

1 Like

Same here. I just tested from cold and dark (default A320, since the A32NX is broken). All fuel pumps on, APU on and running, engine Ign/Start (on quadrant), and then flip Engine 2 switch (on quadrant). Engine never starts. Tried same with engine 1 switch. Engine never starts. Engine switches and mode selector show correctly following in sim, but the engines never start. Without leaving the session, if I simply flip the virtual engine master switches, the engines start right up.

Very disappointing. :frowning:
Long waiting time for TCA quadrant, another week of waiting for an update and after the update the big disappointment. Wasted almost two hours of testing and adjusting without success. :-1:t2:

I wouldn’t say it’s a big disappointment to me; more of a minor one. The throttle levers work correctly and that’s the main thing. The engine switches not starting from cold and dark is annoying, but I can work around that with flipping the virtual switches for now. Same with the engine mode knob. The start switches do shut down the engine when switched off, so that 's still useful at the end of a flight.

I’d say the quadrant is at about 90% of where it should be in game. Hopefully MS/Asobo will adjust the controls/sim so the last couple of problems get fixed soon.

@MoparChrgr69 You mentioned before that your thrust lever are not at the same height or position in the sim but IRL. Mine aren’t too.

I‘m hoping it’s not a hardware error. What do you think about it?

Is this going to solve it straight away without a need to play with the settings?

1 Like