Thrustmaster TCA quadrant still not completely working

A minor change to the sensitivity curve fixed that for me. I turned the “neutral” setting down to -48% on the left throttle and -49% on the right throttle. I left all other sensitivity settings at the default.

Edit, as mentioned above, make sure the firmware for the throttle is the latest. I updated my firmware two days ago when mine arrived. It did not come with the latest (1.56).

1 Like

Ok, I will have a look on my firmware. Do you have a screenshot where you can adjust the sensitivity of the levers?

Edit, it was already on 1.56

See attached…

2 Likes

Managed to set the device to work faultlessly in about 20mins in another simulator.

Looks like after waiting a week for the approved device to work it’s now still an update away from full functionality.

There’s some pretty obvious errors in this implementation.

I also can’t find what to map the engine master switched to? Nothing seems to work.

And I’ve just discovered adjusting the sensitivity destroys the detent positions.

May I propose that the tolliss implementation of being able to adjust the detents manually, and mapping all the switches was nothing short of a masterpiece.

Pains me to say it. Total shambles.

1 Like

I agree. The Quadrant has virtual buttons at the detents so if Asobo would open up the throttle detents in the A320 to be activated by button, then it would be super easy to make sure the detents on the hardware matched in the sim. That would avoid the sensitivity curve missing the proper detents if it is changed.

The engine master switches appear to be mapped in the sim, but something is a bit off since the hardware switches won’t actually start the engine when cold and dark. Even with 3 or 4 things assigned ot each switch, whatever actually starts the engines is missing.

I already thought I was the only one, but not. Same issue on my side. Couldn’t get the engine starters to work. A bit disappointing after such a long wait. If anybody has a solution, let us know. Hope Asobo will fix it soon, so the default is OK too.

1 Like

Engine start also doesn’t work properly here. When switching ENG 1 to ON both engine starters are switched to ON. Also, when only switching ENG 2 to ON it switches back and forth rapidly. Bummer… :frowning:

Also, pressing escape and then resuming the flight causes the spoilers and flaps to fully deploy.

I’m getting really tired of this nonsense. This update, from the A320,to the mods, to the carenado M20R… It broke everything. It completely ruined it for me.

2 Likes

I‘m really disappointed as well. If you’re interested in flying the A20N you need to wait. Without the mod, the liveries and correct inputs by hardware it’s not fun.

4 Likes

Ok, I found a workaround to get the engine switches working (sort of). I assigned Magneto 1 start to button 5 and magneto 2 start to button 6. Buttons 5 and 6 are the two unnamed black buttons to either side of the engine mode selector knob. As I understand it, these two buttons don’t actually exist on a real airbus and are actually warning lights for engine fires. As such, using these buttons on the TCA quadrant won’t take away from any “real” buttons. I also changed button 2’s assignment to “set engine Norm Mode” so that I can hit that after turning the engine mode back to normal and get it to go back to normal in-sim without using the mouse.

These assignments allow you to proceed with engine startup as normal, but you’ll just need to tap button 5 or 6 after flipping the corresponding engine switch. If the mode selector is also in IGN/Start, then the engines will start up just fine.
When powering down, flip the engine switches off and quickly tap button 5 or 6 again, or you can hit buttons 5 and 6 again after the engines have completely started. This is because that function (Magneto1 start, Magneto 2 start) appears to be a toggle and not an ‘only when pressed’ function.

I tried to assign these Magneto functions to the switches as well, but the engine performance got weird - requiring the switch on to start the engine, then switch off once it starts spooling up, then switch back on once it needs fuel flow. That seemed ridiculous to me, so having the Magnetos on the separate buttons seemed to work better for my workflow.

I have included an image of my current Throttle assignments. You may also note that I deleted the assignments for speed brakes and flaps. Since the add-ons with those hardware controls haven’t been released yet, the assignments were causing those systems to activate without any hardware input. The other add on controls (rudder, landing gear, parking brake, etc) don’t seem to be activating without the hardware, so I left them as they are for now.

7 Likes

Hey thanks for this input! Do you use the stock A320 or the flybywire mod? One thing I saw is that the engine switches do not move at all with the mod and I had no real success with your config(engine starts spooling up but it seems like no fuel is being “added”). With the stock A320 the switches move

I’ve just found the same issues with the A32nx mod. I was doing all my testing on the engine switches with a vanilla sim (everything removed from community) to be sure of no conflicts. Once I got that all working earlier, I made the earlier post. I then loaded some community stuff back including the latest A32NX dev version. I just found the same thing. The engine switches don’t work at all with the A32NX. I asked in their discord about the switches but no one has responded and I’m guessing the comment has been buried/overlooked by now.

Edit update: Chatting in Discord with a couple of their devs for the last few minutes now. Hopefully They are getting enough idea of where to start looking to fix it.

3 Likes

My first idea was that it is cool that the quadrant snaps in at TOGA, FLEX and CL.

But after the first flight… it’s nonsense to have only a small area for trhust control between CL and Idle…

Do I have options?

Yes. I’ve thought the same thing. The A320 is very rarely flown with manual throttle. It’s a very fly by wire plane, so from what I understand, the throttles typically stay in the climb detent pretty much all the time (excepting takeoffs and landings, of course). This is probably why having such a small area for manual throttle control was considered a tradeoff when thrustmaster designed the quadrant and it makes sense, to a point.

However, it doesn’t work for other aircraft very well and that’s where different controller profiles comes in. Just save your profile for the A320 and create a new profile for other aircraft (GA, other airliners, etc) and make adjustments as needed to button assignments and sensitivity curves. Then just change to the controller profile that you need based on the aircraft you are flying.

Disclaimer: I haven’t actually tested this out yet, so I’m not 100% positive that each profile will save it’s own sensitivity curves, but if it does, then we should be good. I know the profiles save different button assignments.

1 Like

The first thing I would look to for help would be FSUIPC 7. I would map my switches to FSUIPC 7. The module is free to use at the moment. Charles

http://www.fsuipc.com/

Thanks for this quick fix! :grinning:
But is it only that my throttle for eng1 on my thrustmaster controller both engines in the flightsim? but under control settings Its for throttle 1 axis and the throttle 2 axis works there but the default A320neo uses the throttle 1 for both engines… not tried the A32NX mod yet.

The default mapping has one of the fuel things for engine 2 mapped to the engine 1 switch, presumably by mistake. Remap that one to the engine 2 switch (button 4).

Edit: I reread you r comment and maybe you mean that the throttle lever is doing both engines?? If so, check the mappings in the controller settings. Each throttle lever should control a separate engine.

Does anyone have a slight misalignment of the two individual throttles? I put them both forward, IRL they’re the same distance however in Sim the left throttle is slightly further than the right. Any ideas on fixing this?

100% agree, I have the same issues here. My main problem is that when I put it in iddle the game detects the left engine at 14% power and the right at 7%, and that all the buttons used to turn on the engines do not work even if mapped (except for IGN/Start and cranck)

yes. I noted that in the last paragraph of the original post. Adjust your sensitivity settings to compensate for the hardware manufacturing variance.

1 Like